errore apache

ciao lista,

sto usando una Fedora 4 e ho un problema con moodle (applicazione in php su apache/mysql)

nel log error di apache appare qualcosa del tipo:

*** glibc detected *** /usr/sbin/httpd: double free or corruption (!prev): 0x0ab98198 ***

*** glibc detected *** /usr/sbin/httpd: free(): invalid next size (fast): 0x0ab5f4c8 ***
*** glibc detected *** /usr/sbin/httpd: double free or corruption (fasttop): 0x0a24a1b0 ***
*** glibc detected *** /usr/sbin/httpd: free(): invalid next size (fast): 0x0ab32990 ***
[Wed Jun 14 15:17:31 2006] [notice] child pid 1770 exit signal Segmentation fault (11)
*** glibc detected *** /usr/sbin/httpd: double free or corruption (!prev): 0x09f99458 ***
*** glibc detected *** /usr/sbin/httpd: free(): invalid next size (fast): 0x0a158208 ***
*** glibc detected *** /usr/sbin/httpd: free(): invalid next size (fast): 0x0b2c4868 ***
*** glibc detected *** /usr/sbin/httpd: corrupted double-linked list: 0x0a7cb198 ***

e muore un figlio di apache.

Qualche idea?

kernel-2.6.16-1.2111_FC4
httpd-2.0.54-10.3
php-5.0.4-10.5

Grazie in anticipo
Roberto

* robbe (rdecolle(a)freemail.it) wrote:

sto usando una Fedora 4 e ho un problema con moodle (applicazione in php su apache/mysql)

nel log error di apache appare qualcosa del tipo:

*** glibc detected *** /usr/sbin/httpd: double free or corruption (!prev): 0x0ab98198 ***
> *** glibc detected *** /usr/sbin/httpd: free(): invalid next size (fast): 0x0ab5f4c8 ***
> *** glibc detected *** /usr/sbin/httpd: double free or corruption (fasttop): 0x0a24a1b0 ***
> *** glibc detected *** /usr/sbin/httpd: free(): invalid next size (fast): 0x0ab32990 ***
> [Wed Jun 14 15:17:31 2006] [notice] child pid 1770 exit signal Segmentation fault (11)
> *** glibc detected *** /usr/sbin/httpd: double free or corruption (!prev): 0x09f99458 ***
> *** glibc detected *** /usr/sbin/httpd: free(): invalid next size (fast): 0x0a158208 ***
> *** glibc detected *** /usr/sbin/httpd: free(): invalid next size (fast): 0x0b2c4868 ***
> *** glibc detected *** /usr/sbin/httpd: corrupted double-linked list: 0x0a7cb198 ***

e muore un figlio di apache.

Qualche idea?

kernel-2.6.16-1.2111_FC4
httpd-2.0.54-10.3
php-5.0.4-10.5

Che altri moduli (.so) hai caricato in httpd?

Ad ogni modo ci sono una serie di report (non particolarmente uguali al tuo, ma un'idea
ce la si fa...) che parlano di problemi php+httpd su FC4:

https://bugzilla.redhat.com/bugzilla/buglist.cgi?product=Fedora+Core&version=fc4&component=httpd&component=php&bug_status=NEW&bug_status=VERIFIED&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=NEEDINFO&bug_status=MODIFIED&short_desc_type=allwordssubstr&short_desc=&long_desc_type=allwordssubstr&long_desc=

hth,
Michele