gnome2 probleme bei yelp-1.0.1

Hallo Leute,
ich bin gearde dabei gnome2 zu installieren/compilieren, und jetzt hänge
ich endgültig am 50ten Paket von insgesamt 60! :frowning:

Um genau zu sein bei yelp: Ich führe den Befehl ./configure aus, der
klappt, aber wenn ich dann make ausführe bricht dieser Befehl mit einem
Fehler ab!

Ich denke es hat was mit der Glib zu tun, denn das configure script
schreibt folgendes:

*** to remove the old version of GLib. You may also be able to fix the
error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.

Hast Du probiert "ldconfig" laufen zu lassen?

Bye, Chris.

Hast Du probiert "ldconfig" laufen zu lassen?

Bye, Chris.

ja habe ich schon versucht aber es hat nichts bebracht!

grüße
martin

Ich interpretiere die Fehlermeldung als hättest du 2 Versionen von der
Glib auf deinem System und die ältere überdeckt die neuere. Mach mal ein

locate glib.so

bei mir findet er:
[inspiron]pazzo$ locate glib.so
/usr/lib/libglib.so
/usr/lib/libarts_mpeglib.so

Dann schaust du in welchen Verzeichnissen du diese glib hast und ob alle
in der /etc/ld.so.conf eingetragen sind. Falls nicht trage sie ein und
führe ldconfig als root aus.

Uch habe /usr/lib in meiner ld.so.conf

[inspiron]pazzo$ cat /etc/ld.so.conf
/usr/kerberos/lib
/usr/X11R6/lib
/usr/lib/qt-2.3.1/lib
/usr/lib/wine
/usr/lib/sane
/usr/lib/qt-1.45/lib
/usr/lib/qt-3.0.3/lib
/usr/lib/

Dann probier es nochmals.

Wietere Hinweise:

So findest du das Packet mit dem es installaiert wurde
[inspiron]pazzo$ rpm -qf /usr/lib/libglib.so
glib-devel-1.2.10-5

Mittels ldd findet man oft fehler in der lib oder kann man
Versionsabhängigkeiten überprüfen:
ldd -v -d -r /usr/lib/libglib.so

byez
Patrick