HDD problems RH 7.2 ext3 INSPIRON 8100

Hello,

I just got an INSPIRON 8100 with a 30GB hard disk. I got it with WinME.
Using parted I shrinked the WinME partition to 3 GB, than I recreated
the suspend to disk partition with DELLs mks2d.exe. And then finally I
installed RH 7.2, to which I assigned all the remaining free space. I
would like to leave WinME, because I need an MSAccess program for a
presentation and some gameing would be nice, if VMWare will do the job I
can assign even that space to linux :slight_smile:

RH works, didn't test the interfaces PCMCIA, IrDA, USB, Firewire,
internal modem, ...
But X and the internal EthernetCard work perfectly :slight_smile:

My big problem, I have errors on the HDD, e.g. I have the file default
under /home/pazzo/.gnome/panel.d/ giving me the following problems:

If I execute 'ls' I get the file listed
with 'ls -l' I don't see it
with 'cat default' I get an input/output error

Now it manifested to me, because my custom changes in gnome got lost on
every new start.

Did some of u get the same problem or could give me a hint? I suspect
the ext3 file system, which RH 7.2 installs as default, and I followed
the leader :wink:
A friend of mine told me today, it isn't ext3, but the partitioning
layout, I should put the boot partition at the beginnning. Here my
actual layout:
  START END TYPE FS FLAGS
1
     0.031 3074.941 primary FAT boot, lba
2
  3074.941 3349.489 primary
3
  3349.490 3396.555 primary ext3
4
  3396.555 28615.781 extended
5
  3396.586 13633.286 logical
ext3
6
13633.317 14143.161 logical linux-swap
7
14143.192
28615.781
logical
ext3

1 WinME
2 suspend to disk
3 /boot
5 /
7 /home

Now, before changing everything, I would like to know if someone can
conferm his theory or even conferm that ext3 works. Otherwise I will
reinstall RH with ext2.

Or may be u know another solution to fix this errors. Ohh, I should
mention, at one of the first system boots even / was corrupted, most
files in /sbin/ were not accessible, but after rebooting everything was
fine again.

thx
Patrick

Now, before changing everything, I would like to know if someone can
conferm his theory or even conferm that ext3 works. Otherwise I will
reinstall RH with ext2.

Ext3 works just fine. If you feel like switching back to ext2 you don't
have to format the partition, just mount it as ext2 and the journaling
data won't be affected.

:wink:

Ciao,
Michele

Thx Michele!

E per correggere gli errori uso fsck? O ci sono altri tools?

byez
Patrick

baldessari(a)tiscalinet.it wrote:

Hehe faccendo il remount come ext2 non mi dà + l'errore ho anche fatto un
mv default default_SIK
ed ha funzionato!

Mi sà che userò ext2 per adesso.

byez
Patrick

pohnewein(a)prodata.it wrote:

* Patrick Ohnewein (pohnewein(a)prodata.it) wrote:

Hehe faccendo il remount come ext2 non mi dà + l'errore ho anche fatto un
mv default default_SIK
ed ha funzionato!

Mi sà che userò ext2 per adesso.

byez
Patrick

Accertati bene che sia un discorso ext3, perche' ho veramente ancora da
sentire problemi su ext3 (se usi RH72 pero' aggiorna ad 2.4.9-7) e se
sei convinto che sia un prob. di ext3: bugzilla.redhat.com/bugzilla :slight_smile:

Saluti,
Michele