il mio apache ha perso php (colpa di comanche?)

Salve ragazzi,
sperimenta qui, sperimenta li, i danni prima o poi si fanno.
Questa volta non riesco a ripararli da solo.

Avevo un Apache, con degli php (di phpMyAdmin, per MySQL)
funzionava tutto bene.

Per risolvere un altro problema con Apache ho deciso di
installare e usare Comanche.

Il risultato è stato che le pagine PHP mi vengono mostrate con
l'opzione di Salvare/Aprire-Con-Applicazione

Cosa avrà mai fatto sto' Comanche ai miei file di configurazione?
Ne avevo salvati 3, ma lui ha toccato quelli della SuSE (che non
pensavo andasse a toccare)

Ho deciso di riconfigurare tutto a mano, ma la cosa buffa è che
persino con un banalissimo

Salve ragazzi,
sperimenta qui, sperimenta li, i danni prima o poi si fanno.
Questa volta non riesco a ripararli da solo.

Avevo un Apache, con degli php (di phpMyAdmin, per MySQL)
funzionava tutto bene.

Per risolvere un altro problema con Apache ho deciso di
installare e usare Comanche.

Il risultato è stato che le pagine PHP mi vengono mostrate con
l'opzione di Salvare/Aprire-Con-Applicazione

Cosa avrà mai fatto sto' Comanche ai miei file di configurazione?
Ne avevo salvati 3, ma lui ha toccato quelli della SuSE (che non
pensavo andasse a toccare)

Ho deciso di riconfigurare tutto a mano, ma la cosa buffa è che
persino con un banalissimo
---------------
User wwwrun
Group nogroup
ServerName scheggia
DocumentRoot /usr/local/httpd/htdocs
----------------
Le cose vanno male, perché mi mostra i sorgenti delle pagine.
Leggi qui, leggi la. Modifica qui, aggiungi la.
NULLA
Ho rimesso i file che avevo prima (ma non prima di Comanche) e chiedo

Domanda:
Come cavolo si fa a dire ad Apache di mostrarmi phpMyAdmin come faceva
prima?

Tutto chiaro, vero?
No? Neanche a me.
Fatemi le domande su cosa si trova nei diversi file, e cercherò
di aiutarvi ad aiutarmi.

grazie, anche solo per provare ad aiutarmi
ciao, antonio

_______________________________________________
https://secure.pcnotruf.net/mailman/listinfo/lugbz-list
LUGBZ is pcn.it-powered

In /etc/httpd/httpd.conf
   <IfModule mod_php3.c>
    AddType application/x-httpd-php3 .php3
    AddType application/x-httpd-php3-source .phps
    AddType application/x-httpd-php3 .phtml
    </IfModule>

Ciao Giuliano & lugbz.
Ancora nulla. Anzi no :slight_smile:
Ma prima di dire come è andata a finire scrivo cosa pensavo fino a
qualche secondo fa

Prossimo problema: insegnare a Mozilla a ricaricare la pagine anche se
il server dice 304.
[si, lo so, "Reload", ma il mio Mozilla è più testardo di me]

Molto probabilmente nelle preferences di mozilla sotto
advanced->cache hai selezionato:

  Compare the page in the cache to the page on the network:

   * when the page is out of date

In quel modo Mozilla fa un request condizionale insieme alla
data del documento nel cache. Il tuo server quindi ha visto che il
documente non e` stato modificato (infatti hai smanettato solo con
la configurazione non con i documenti) e ritorna
un "304 not modfified".

Aparte quando fai sviluppo, questa opzione e` consigliabile.
Tu prova a cambiarla in:

  * every time I view the page

Cosi` Moz. fa requests incondizionati.

Bye, Chris.

PS: non sei il primo che rimane vittima dei vari meccanismi di caching
usati in HTTP e nei browser.

Grazie Chris,
Da qualche parte mi dovrò leggere qualcosa sull'argomento, e capire
meglio cosa significano le quattro diverse opzioni in Mozilla
Spesso mi accontento di sapere che le cose funzionano, senza capire
bene il perché (logica del minimo impegno :slight_smile:
ciao,
antonio

> Prossimo problema: insegnare a Mozilla a ricaricare la pagine anche se
> il server dice 304.
> [si, lo so, "Reload", ma il mio Mozilla è più testardo di me]

Molto probabilmente nelle preferences di mozilla sotto
advanced->cache hai selezionato:

  Compare the page in the cache to the page on the network:

   * when the page is out of date

Avevo:
Compare the page ...
   Automatically

Aparte quando fai sviluppo, questa opzione e` consigliabile.
Tu prova a cambiarla in:

  * every time I view the page

Dopo aver capito l'intoppo ho messo
Once per session
Me l'ha ricaricato e a quel punto ho rimesso "Automatically"
Personalmente non so cosa voglia dire, ma non mi aveva mai creato
problemi (= non me ne sono mai accorto)