imap und pop probleme mit Umlauten im password auf Debian

Als generelle Regel wuerde ich aber von der Verwendung von
nicht-ASCII Zeichen in Passwoertern absehen, da du eventuell

keine

Zugriffsmoeglichkeit auf deine Daten hast, wenn dir keine

deutsche

Tastatur zur Verfuegung steht. (Ok, von Copy-and-Paste aus
Zeichensatztabellen einmal abgesehen)

Es geht da eigentlich weniger um mich, sondern um eine Installation
bei einem Kunden. Es kommt immer wieder vor, dass user sich nicht
verbinden können da sie eben einem Umlaut im Passwort verwenden...
Der Kunde möchte nun das Problem lösen ohne seinen Benutzer den
Umlaut
zu verbieten....

Ich glaube der Trick ist Konsistenz:
nehmen wir an du schickst ein ue im Paswort dass der Server nicht
als ue interpretiert -> kein Problem, wenn Du das *immer* gleich
schickst.

Wenn jetzt natuerlich einer hergeht und setzt sein password ueber
eine Web-UI wo der Browser/Webserver sich das Encoding ausderhandeln
und es kommt daher als ue an und nachher will er damit ueber einen
mailclient einloggen, der einfach sein eigenens Encoding schickt
ohne sich Gedanken zu machen: dann gibt es ein Problem...

Eine griffige Loesung habe ich aber auch nicht...
Vielleicht kann man die verschiedenen Stellen wo sein ein Password
gesetzt/geaendertt wird einschraenken und schauenen dass sie alle
konsistent sind?

Bye,
Chris.

Oder vielleicht kann man zentral im LDAP Server eine Option setzen, dass
Umlaute nicht erlaubt sind?

Ich kann mir aber nicht vorstellen, dass es heutzutage mit Umlaute in
Passwörter Probleme geben kann. Sprich hier aber aus dem Bauch heraus... :stuck_out_tongue:

Patrick

Hallo,

Um jetzt noch mal zusammen zufassen ist das Problem nicht so einfach
lösbar!
Die Passwörter werden nicht über dem Mailclient verändert sondern über
Windows, da es ja das Active Directory Passwort ist.
Der Mailclient ist nicht in der Lage das Passwort richtig zu schicken
(im richtigen CHARSET), desshalb kann ich mich nicht einlogen. POP und
IMAP (in meinem Fall cyrus / courrier) sind nicht im Stande den
CHARSET zu erkennen und zu konvertieren.

Lösung:
- Umlaute im Passwort verbieten
??? Kann man das im Active Directory einstellen, wenn ja wie ???
??? Kennt jemand andere Lösungen für mich ???

Grüße
Martin

Patrick Ohnewein schrieb:

Eine griffige Loesung habe ich aber auch nicht...
Vielleicht kann man die verschiedenen Stellen wo sein ein Password
gesetzt/geaendertt wird einschraenken und schauenen dass sie alle
konsistent sind?

Oder vielleicht kann man zentral im LDAP Server eine Option setzen, dass
Umlaute nicht erlaubt sind?

Ich kann mir aber nicht vorstellen, dass es heutzutage mit Umlaute in
Passwörter Probleme geben kann. Sprich hier aber aus dem Bauch

heraus... :stuck_out_tongue: