kernel-smp-2.6.13-15 AMD64

Hallo. Habs geschafft, auf meinem AMD64 Läuft jetzt SUSE 10.0

Hab den kernel kernel-smp-2.6.13-15 installiert, der läuft aber anscheinend
noch im 32-Bitmodus 8ist aber einj 64Bit kernel.)

Problem 1:
Hab nach Bootparametern gesucht ob es einen gibt für 64Bitmode, aber nichts
gefunden. Hab leider keine Ahnung wie ich den Kernel zwingen soll im
64Bit-Mode heraufzufahren. Hat jemand schon erfahrung damit gemacht?

Problem 2:
im selben PC Läuft eine ATI Radeon 9800. Hab mir Von Ati das rpm-paket
besorgt und installiert:

Anleitung dazu
http://linux.wordpress.com/2005/10/11/suse-100-ati-drivers-installation/

hab den "treiber" anschließend in SaX geladen
sax2 -r -m 0=fglrx -b /usr/share/doc/packages/fglrx/sax2-profile

bekomme aber wenn ich den test mit glxgears mache immer noch nur eine
framerate von 102 FPS zusammen. der "treiber" wurde anscheinend nicht
richtig geladen

Grüsse Alan

Problem 1:
Hab nach Bootparametern gesucht ob es einen gibt für 64Bitmode, aber nichts
gefunden. Hab leider keine Ahnung wie ich den Kernel zwingen soll im
64Bit-Mode heraufzufahren. Hat jemand schon erfahrung damit gemacht?

Sag' uns mal die Ausgaben von
  uname -a

und von
  arch

Problem 2:
im selben PC Läuft eine ATI Radeon 9800. Hab mir Von Ati das rpm-paket
besorgt und installiert:

Anleitung dazu
http://linux.wordpress.com/2005/10/11/suse-100-ati-drivers-installation/

hab den "treiber" anschließend in SaX geladen
sax2 -r -m 0=fglrx -b /usr/share/doc/packages/fglrx/sax2-profile

bekomme aber wenn ich den test mit glxgears mache immer noch nur eine
framerate von 102 FPS zusammen. der "treiber" wurde anscheinend nicht
richtig geladen

Hier wuerde uns die Ausgabe von
  glxinfo

interessieren (nur die ersten 10 Zeilen), nicht die ganzen Listen!

Bye, Chris.

Problem 1:
Hab nach Bootparametern gesucht ob es einen gibt für 64Bitmode, aber
nichts
gefunden. Hab leider keine Ahnung wie ich den Kernel zwingen soll im
64Bit-Mode heraufzufahren. Hat jemand schon erfahrung damit gemacht?

Chris wrote:
Sag' uns mal die Ausgaben von
  uname -a
und von
  arch

#uname -a:

Linux linux 2.6.13-15-smp #1 SMP Tue Sep 13 14:56:15 UTC 2005 i686 athlon
i386 GNU/Linux

#arch:

i686

Problem 2:
im selben PC Läuft eine ATI Radeon 9800. Hab mir Von Ati das rpm-paket
besorgt und installiert:

Anleitung dazu
http://linux.wordpress.com/2005/10/11/suse-100-ati-drivers-installation/

hab den "treiber" anschließend in SaX geladen
sax2 -r -m 0=fglrx -b /usr/share/doc/packages/fglrx/sax2-profile

bekomme aber wenn ich den test mit glxgears mache immer noch nur eine
framerate von 102 FPS zusammen. der "treiber" wurde anscheinend nicht
richtig geladen

Hier wuerde uns die Ausgabe von
glxinfo
interessieren (nur die ersten 10 Zeilen), nicht die ganzen Listen!

#fglrxinfo

display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

# vendor sollte nach installation ATI sein und nicht mesa...

>> Problem 1:
>> Hab nach Bootparametern gesucht ob es einen gibt für 64Bitmode, aber
>> nichts
>> gefunden. Hab leider keine Ahnung wie ich den Kernel zwingen soll im
>> 64Bit-Mode heraufzufahren. Hat jemand schon erfahrung damit gemacht?

> Chris wrote:
> Sag' uns mal die Ausgaben von
> uname -a
> und von
> arch

#uname -a:

Linux linux 2.6.13-15-smp #1 SMP Tue Sep 13 14:56:15 UTC 2005 i686 athlon
i386 GNU/Linux

#arch:

i686

Sieht schlecht aus,
uname -a und arch sollten x86_64 zeigen, nicht i386/i686.

Von mir aus gesehen hast Du ein 32bit Linux installiert. Ich glaube
nicht, dass ein Bootparameter daran etwas aendern kann.

display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

# vendor sollte nach installation ATI sein und nicht mesa...
#

#glxinfo:

name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2

Du hast recht, auch hier wird nicht der von Dir installierte Treiber
verwendet, HW OpenGL ist aus (direct rendering: No).

Hat SAX2 keine Fehler angezeigt?
Hast Du vielleicht einen 64 bit Treiber installiert (der Meinung
Du haettest ein 64 bit System) und das 32 bit System konnte
nichts mit dem?

Bye,
Chris

Chris wrote:

Sieht schlecht aus,
uname -a und arch sollten x86_64 zeigen, nicht i386/i686.

Von mir aus gesehen hast Du ein 32bit Linux installiert. Ich glaube
nicht, dass ein Bootparameter daran etwas aendern kann.

hab aber den kernel -default bei der installation ausgehakt und
den kernel -smp ausgewählt (für 64bit prozessoren)

oder muss ich mir da eine spezielle suse 10.0 distro dvd besorgen beim
booten der setupdvd bekam ich ganz am anfang die meldung your're installing
a 32bit software on a 64bit system. deswegen habe ich den kernel -smp selber
ausgewählt.

Hat SAX2 keine Fehler angezeigt?
Hast Du vielleicht einen 64 bit Treiber installiert (der Meinung
Du haettest ein 64 bit System) und das 32 bit System konnte
nichts mit dem?

wollte den 64bit treiber laden, da hat das system gemeckert das ich einen
64bit treiber auf ein 32 bitlinux wie du so schön sagst installiere

deswegen hab ich den 32bit treiber installiert.
Sax gab keine probleme bis auf das die 3dbeschleunigung nicht geladen werden
konnte.

Bye,
Alan

Von mir aus gesehen hast Du ein 32bit Linux installiert. Ich glaube
nicht, dass ein Bootparameter daran etwas aendern kann.

hab aber den kernel -default bei der installation ausgehakt und
den kernel -smp ausgewählt (für 64bit prozessoren)

oder muss ich mir da eine spezielle suse 10.0 distro dvd besorgen beim
booten der setupdvd bekam ich ganz am anfang die meldung your're
installing a 32bit software on a 64bit system. deswegen habe ich den
kernel -smp selber ausgewählt.

Ja, das sind verschiedene CDs/DVDs. Alle Anwendungen werden fuer
die jeweilige Architektur (x86, x86_64, oder PPC u.v.m.) eigens
uebersetzt.

Die 64 bit Architekturen von AMD und Intel (AMD64 und EM64T,
unter Linux einfach x86_64 genannt) sind *abwaerts* kompatibel
zu x86, daher konntest Du die Installation durchfuehren (und erhielst
lediglich den Hinweis, dass Du die Architektur nicht voll ausnutzt).

Du kannst aber auch mit einem 32bit System weiterleben. Erwarte
nicht, dass der Umstieg auf 64bit (auf einem Desktop) was Gott was
bringt. Das bringt wohl etwas wenn Du Prozesse hast, die sehr
viel RAM benoetigen (>2GB pro Prozess) oder eine bestimmte Art
von Berechnungen anstellst. Im Moment faehrst Du mit 32bit noch
gut.

Dein huebscher AMD64 Prozessor arbeitet auch im 32bit Modus
sehr performant, dank anderer Features, wie. z.B. seiner schnellen
RAM Anbindung, etc...

Damals beim Umstieg 16->32 war das eine ganz andere Geschichte...

wollte den 64bit treiber laden, da hat das system gemeckert das ich
einen 64bit treiber auf ein 32 bitlinux wie du so schön sagst
installiere

deswegen hab ich den 32bit treiber installiert.
Sax gab keine probleme bis auf das die 3dbeschleunigung nicht geladen
werden konnte.

Ah, ja... dann ist eben nichts mit hardware-gestuetzten OpenGL :open_mouth:

Da muesste man jetzt die SUSEler auf der Liste zu Wort kommen lassen,
wie man den Sax2 da am besten gefuegig machen koennte (habe selbst
grade keine SUSE laufen...) Liste?

Bye, Chris.