Mag Consisto-Webserver keine Linux-Clients?

Hallo Liste,

ich habe jetzt schon mehrmals gemerkt, dass Seiten, die von der Consisto
gehostet werden (z.B. www.brixen.it) bei mir unter Linux praktisch
unbenutzbar sind, weil die Daten nur byteweise hereintröpfeln und der
Seitenaufbau schließlich oft mit einem Timeout abbricht. Habe es mit Firefox,
Konqueror und Lynx getestet sowohl mit als auch ohne Proxy (wwwoffle). Immer
dasselbe Ergebnis.
Von meinem WindowsXP-Notebook aus (mit meinem Linux-PC als Gateway) kann ich
dagegen die Webseiten problemlos aufrufen, vorausgesetzt ich benutze den
Linux-PC nur als Gateway aber nicht als Proxy.

Mich würde jetzt interessieren, ob bei euch dasselbe Phänomen auftritt. Falls
ja, sollte man (bzw. würde ich) die Consisto darauf aufmerksam machen. Wenn
nein, hat vielleicht jemand eine Erklärung für das Problem? Es tritt wirklich
nur bei Webseiten von der Consisto auf.

Grüße
Christoph

Hallo Liste,

ich habe jetzt schon mehrmals gemerkt, dass Seiten, die von der
Consisto
gehostet werden (z.B. www.brixen.it) bei mir unter Linux praktisch
unbenutzbar sind, weil die Daten nur byteweise hereintröpfeln und der
Seitenaufbau schließlich oft mit einem Timeout abbricht. Habe es mit
Firefox,
Konqueror und Lynx getestet sowohl mit als auch ohne Proxy
(wwwoffle). Immer
dasselbe Ergebnis.
Von meinem WindowsXP-Notebook aus (mit meinem Linux-PC als Gateway)
kann ich
dagegen die Webseiten problemlos aufrufen, vorausgesetzt ich benutze
den
Linux-PC nur als Gateway aber nicht als Proxy.

Mich würde jetzt interessieren, ob bei euch dasselbe Phänomen
auftritt.

Geht bei mir sowohl unter Mac/Safari als auch unter Linux/Firefox prima
(durch OpenBSD Gateway ueber Telecom ADSL).

Ich glaube nicht, dass das Client-Betriebssystem etwas damit zu tun hat.

Was fuer Internet Provider hast Du denn? Vielleicht hat es damit zu tun?

Falls
ja, sollte man (bzw. würde ich) die Consisto darauf aufmerksam
machen. Wenn
nein, hat vielleicht jemand eine Erklärung für das Problem? Es tritt
wirklich
nur bei Webseiten von der Consisto auf.

Ich tippe eher nicht auf ein Problem bei denen. Wie sieht Dein
traceroute aus?

Meines sieht so aus:

chris(a)mars:~$ traceroute www.brixen.it
traceroute to www.brixen.it (195.254.235.37), 30 hops max, 40 byte
packets
  1 neptunus.home.lan (192.168.1.1) 0.275 ms 0.240 ms 0.216 ms
  2 192.168.0.2 (192.168.0.2) 1.076 ms 1.119 ms 1.027 ms
  3 * * *
  4 host9-158-static.36-88-b.business.telecomitalia.it (88.36.158.9)
10.020 ms 9.532 ms 8.818 ms
  5 217.141.106.142 (217.141.106.142) 9.105 ms 9.147 ms 9.324 ms
  6 172.17.4.17 (172.17.4.17) 14.386 ms 14.138 ms 14.733 ms
  7 151.99.75.226 (151.99.75.226) 16.454 ms 16.765 ms 15.756 ms
  8 gw-mi-nap4-r-mi265.opb.interbusiness.it (151.99.98.138) 16.810
ms 13.241 ms 13.032 ms
  9 85.36.9.138 (85.36.9.138) 13.283 ms 13.563 ms 13.273 ms
10 PO2-0.mil-cal-access-1.interoute.net (212.23.42.85) 17.231 ms
17.148 ms 17.426 ms
11 84.233.248.210 (84.233.248.210) 20.467 ms 20.710 ms 19.893 ms
12 dis3-tn-vl1001.aknet.it (213.21.128.141) 16.262 ms 17.906 ms
17.180 ms
13 213.21.139.171 (213.21.139.171) 24.131 ms 25.040 ms 25.298 ms
14 reserved-225165.rol.raiffeisen.net (195.254.225.165) 26.841 ms
25.189 ms 27.329 ms
15 * * *

Bye,
Chris.

Hallo Christoph,

auch bei mir funktioniert es ohne Probleme unter Ubuntu 7.04 mit
Firefox 2.0.

Ich würde versuchen das Problem einzuschränken z.B. über einen anderen
Provider versuchen.
Komisch finde ich es aber schon dass es unter M$ funktioniert und
unter Gnu/Linux nicht.

Grüße
~Martin

Christoph Federer schrieb:

Hallo Liste,

ich habe jetzt schon mehrmals gemerkt, dass Seiten, die von der Consisto
gehostet werden (z.B. www.brixen.it) bei mir unter Linux praktisch
unbenutzbar sind, weil die Daten nur byteweise hereintröpfeln und der
Seitenaufbau schließlich oft mit einem Timeout abbricht. Habe es mit

Firefox,

Konqueror und Lynx getestet sowohl mit als auch ohne Proxy (wwwoffle).

Immer

dasselbe Ergebnis.
Von meinem WindowsXP-Notebook aus (mit meinem Linux-PC als Gateway)

kann ich

dagegen die Webseiten problemlos aufrufen, vorausgesetzt ich benutze den
Linux-PC nur als Gateway aber nicht als Proxy.

Mich würde jetzt interessieren, ob bei euch dasselbe Phänomen auftritt.

Falls

ja, sollte man (bzw. würde ich) die Consisto darauf aufmerksam machen.

Wenn

nein, hat vielleicht jemand eine Erklärung für das Problem? Es tritt

wirklich

Hallo,

2008/5/7 Christoph Federer <fedi73(a)interfree.it>:

Mich würde jetzt interessieren, ob bei euch dasselbe Phänomen auftritt. Falls
ja, sollte man (bzw. würde ich) die Consisto darauf aufmerksam machen. Wenn
nein, hat vielleicht jemand eine Erklärung für das Problem? Es tritt wirklich
nur bei Webseiten von der Consisto auf.

Auch bei mir funktioniert problemlos, unter kubuntu 7.10, FF 2.0.0.14
& konqueror 3.5.8. Wass ich komisch finde, ist dass wenn ich
http://www.bressanone.it/ statt www.brixen.it lade, hat die Seite die
deutsche Sprache als default... :slight_smile:

Stefano

Christoph Federer wrote:

Hallo Liste,

ich habe jetzt schon mehrmals gemerkt, dass Seiten, die von der Consisto
gehostet werden (z.B. www.brixen.it) bei mir unter Linux praktisch
unbenutzbar sind, weil die Daten nur byteweise hereintroepfeln und der
Seitenaufbau schließlich oft mit einem Timeout abbricht.

Hmm, das koennte veilleicht auf eine zu grosse MTU im Linux TCP/IP stack
zurueckzufuehren sein.
Versuch einmal die MTU auf einen etwas kleineren Wert (etwa 1200 oder auch
1000) zu setzen und zu sehen ob das etwas bringt.

Ich bin momentan leider nicht vor einer Linux MAschine und kann dir keine
Anleitung dazu geben, aber ich denke Google duerfte da genug Treffer
haben.

HTH
Thomas

Du hast recht.
Das Problem waren die IPTables-Einstellungen, die ich über guarddog
konfiguriert habe. Ich hatte zwar bei meinen tests die Firewall abgeschalten,
aber irgendetwas muss trotzdem noch in der Filterkette hängengeblieben sein.
Erst nach einem Reboot hat der Seitenaufruf plötzlich funktioniert.
Trotzdem ist es schon merkwürdig, dass die Probleme nur bei den Seiten von
der Consisto aufgetreten sind und auch nur wenn ich sie direkt vom PC aus
aufgerufen habe.

Grüße
Christoph

Wie ich schon an Chris geschrieben habe, bin ich inzwischen darufgekommen,
dass mir die IPTables-Einstellungen von guarddog die Probleme verursacht
haben. Vielleicht wurde dadurch die richtige Verarbeitung von fragmentierten
Paketen verhindert?
Übrigens gehe ich über ISDN ins Internet, weil es hier wo ich wohne ADSL gibt.

Grüße
Christoph

Soll natürlich heißen, "weil es hier wo ich wohne _kein_ ADSL gibt."

Grüße
Christoph

Christoph Federer wrote:

Hmm, das koennte veilleicht auf eine zu grosse MTU im Linux TCP/IP stack
zurueckzufuehren sein.
Versuch einmal die MTU auf einen etwas kleineren Wert (etwa 1200 oder
auch
1000) zu setzen und zu sehen ob das etwas bringt.

Wie ich schon an Chris geschrieben habe, bin ich inzwischen darufgekommen,
dass mir die IPTables-Einstellungen von guarddog die Probleme verursacht
haben. Vielleicht wurde dadurch die richtige Verarbeitung von
fragmentierten Paketen verhindert?

Ich hatte einmal ein aehnliches Problem aber im Zusammenhang von ADSL und
fehlkonfigurierten Firewalls auf einem Server:

1) Client schickt Anfrage an den Server (ueber ADSL).
2) Server schick Packet mit knapp unter 1500 bytes zurueck an Provider.
3) Provider versucht das Paket in einen weiteren Frame (PPPoE, wimre) zu
legen, sprengt damit aber die maximale Paketgroesse.
3) Provider schickt ein Fragmentation Needed an Server.
4) Server verwirft das ICMP Paket welches nur von Boesen Hackerz kommen kann.
5) Client wartet und wartet...

Übrigens gehe ich über ISDN ins Internet, weil es hier wo ich wohne ADSL
nicht gibt.

Damit ist meine Erklaerung natuerlich muessig. :slight_smile:

Thomas

Hallo Liste,

habe folgende Situation:

2 x PCs mit Windows 2000
1 x PC mit Linux (Ubuntu)

Momentan läuft auf den Windows 2000 PC eine MS Access Datenbank.

Damit man auch vom Linux PC auf die DB zugreifen kann, möchte
ich die DB auf eine offene DB, z.B Postgres migrieren.

Die DB enhält Adresslisten und hat eine Form zur Eingabe/Suche
der Daten. Ist ca. 11 MB gross;

Als Interface zur DB könnte auf den Linux PC Openoffice Verwendung finden.

Wie kann das a besten anstellen?

vielen dank.

lg konrad

Hallo Konrad,

ich würde auf dem Windows Rechner mit OpenOffice.org über die ODBC
Schnittstelle versuchen, die Access DB zu öffnen und dann die Daten in
die neue DB (immer über OOo ODBC Verbindung) zu verschieben.

Es wird auch andere MÖglichkeiten mit dedizierte ODBC Tools geben, aber
das mit OOo würde ich zuerst mal probieren.

Warum PostgreSQL und nicht die interne DB HSQLDB[1] von OOo oder
Derby[2] die integrierte DB, die jetzt mit Java mitgeliefert wird?
Nichts gegen PostgreSQL, aber der Verwaltungsaufwand von PG ist für
deine Anwendung vielleicht übertrieben, oder?

Happy hacking!
Patrick

[1] http://hsqldb.org/
[2] Apache Derby

konrad hofer schrieb: