mi sono messo nei guai con Debian/apt-get :-{

Ciao,

ho un problema con un installazioen Debian (3.0).

Ho fatto solo un base install perche` non volevo fare altro che
provare un dato software. Ho aggiunto "unstable" nelle mie sources,
perche` il software in questione e` proprio considerato unstable.

Prima qui avevo sbagliato con la sinstassi ma ho corretto il
problema e ho fatto un apt-get update. Finqui tutto ok. Penso.

Ma ora "apt-get install" sembra essersi bloccato un po. Su cose
non banali (tipo vim :wink: mi da:

$ apt-get install postgresql

--->8---
Reading Package Lists...
Building Dependency Tree...
The following extra packages will be installed:
  libpam-modules libpam0g libreadline4 passwd postgresql-client python
  python2.2
The following NEW packages will be installed:
  postgresql postgresql-client python python2.2
4 packages upgraded, 4 newly installed, 0 to remove and 83 not upgraded.
Need to get 0B/6398kB of archives. After unpacking 16.9MB will be used.
Do you want to continue? [Y/n]
--->8---

Y

--->8---
E: This installation run will require
temporarily removing the essential package libpam-modules due to a
Conflicts/Pre-Depends loop. This is often bad, but if you really want to
do it, activate the APT::Force-LoopBreak option.
E: Internal Error, Could not early remove libpam-modules
--->8---

E la cosa si ferma li` senza risultato.
Con almeno un altro pacchetto ho visto precisamente lo stesso
errore.

Domanda: sono andato a mettermi nei guai perche` sto usando il
branch unstable? D'altra parte "unstable" in Debian non dovrebbe
voler dire che apt-get install non funziona piu` - al limite
la versione del pacchetto sara bacata, no?

Aiuto :-{

Bye, Chris.

* Mailing List (list(a)1006.org) wrote:

E: This installation run will require
temporarily removing the essential package libpam-modules due to a
Conflicts/Pre-Depends loop. This is often bad, but if you really want to
do it, activate the APT::Force-LoopBreak option.
E: Internal Error, Could not early remove libpam-modules

Domanda: sono andato a mettermi nei guai perche` sto usando il
branch unstable? D'altra parte "unstable" in Debian non dovrebbe
voler dire che apt-get install non funziona piu` - al limite
la versione del pacchetto sara bacata, no?

apt-get -u upgrade -o APT::Force-LoopBreak=true

mfg,
Michele

Ciao Michele,

apt-get -u upgrade -o APT::Force-LoopBreak=true

questo fa un downgrade della Version?

Mi servirebbe un Downgrade dalla unstable alla stable o almeno testing.

Infatti ero contento che Chris abbia fatto la domanda prima di me :wink:

Happy hacking!
Patrick

* Patrick Ohnewein (patrick.ohnewein(a)lugbz.org) wrote:

Ciao Michele,

>apt-get -u upgrade -o APT::Force-LoopBreak=true

questo fa un downgrade della Version?

Nope, semplicemente attiva l'azione per fare il loopbreak e quindi
riuscire a fare l'upgrade ad unstable (o testing).

Mi servirebbe un Downgrade dalla unstable alla stable o almeno testing.

mmh. Credo che il supporto per una manovra del genere sia abbastanza
limitato. In giro trovi cmq. diversi mini howto e/o esperienze [io ho
sempre tre partizioni stable/testing/unstable ;)]

i.e. : http://people.debian.org/~osamu/downgrade.html

mfg,
Michele

> Domanda: sono andato a mettermi nei guai perche` sto usando il
> branch unstable? D'altra parte "unstable" in Debian non dovrebbe
> voler dire che apt-get install non funziona piu` - al limite
> la versione del pacchetto sara bacata, no?

apt-get -u upgrade -o APT::Force-LoopBreak=true

Grazie Michele!

Ho una bella e consistente unstable ora :wink:

Bye, Chris.