Mounten der externen USB-Festplatte usw.

Hallo!
Ich hab ein Problem mit dem mounten von Geräten. Auf meinem Debian Notebook werden neu eingesteckte Gertäte nicht erkannt, ich muss sie alle manuell mounten. dann habe ich oft keinen Zugriff und oft wieder mal nur wenige minuten, bis ein Zugriffsfehler auftritt. Auch die Windowspartitionen werden nicht erkannt und meine externe Festplatte auch nicht. Letztere wird zwar gemountet aber ich habe keinen Zugriff...nun stelle ich mir die Frage, ob das mit dem Format der externen Festplatte zusammenhängen kann? Ist das nicht ein normaler Massenspeicher wie ein USB-Stick? Auf der externen Festplatte speichere ich von Windows wie auch von Linux(würd ich gern) meine Sicherungen, aber genau des geht net.

ich verwende $ mount /dev/sda1 /mnt

Stimmt hier der Zielornder? Und was ist zusätzlich einzugeben wenn ich auf obige Eingabe folgende Ausgabe erhalte?

mount: you must specify the filesystem type

Damit ich endlich mal irgendeine Sicherung machen kann habe ich mir eine knoppix-cd runtergeladen und mit der gebootet...dort funkt alles genau so wie ich mir das wünschen würde, nur eines nicht...ich kann zwar die einzelnen Festplatten lesen, wenn ich aber in Knoppix von der hda7 nach sda1 kopieren will krieg ich einen Zugriffsfehler...auch zwischen den Festplatten kann ich nichts herumkopieren. mir it klar dass FAT32 in Linux nur lesbar ist und deswegen das nicht geht aber auf die externe müsste ich doch zugreifen können? Oder, wie gesatg, muss ich diese auch neu in ext3 oder reiserfs formatieren(Größe: 300GB)?

Wie kann ich machen dass hotgeplugte USB-geräte automatisch gemountet werden? Macht man das in /etc/fstab?
Aber wenn sich da die Bezeichnung andauernd ändert, geht des ja net oder?

Warum kriege ich eigentich beim einstecken der ext. Festplatte ein sda und ein sda1? Und warum wird dem usb stick oft sdb zugewiesen und oft sdc???

kann mir aus dem ganzen keinen Reim machen...mein Debian Handbuch von Frank Ronneburg weiß darüber auch nichts...

lg Günther

attachment.htm (2.2 KB)

Hallo,
externe Festplatten haben genauso (Recht auf) ein Dateisystem wie alle
anderen Laufwerke, USB-Sticks mit inbegriffen. Letztere benutzen
uebrigens auch das FAT System (obwohl man auch ext2/3 Sticks formatieren
kann).
Das Problem ist also, welche Zugriffsrechte du bzw. dein Benutzer hat.
Auf fat kann linux problemlos lesen und schreiben. Mit ntfs geht's zwar
mittlerweile auch, die Datenintegritaet ist beim schreiben aber nicht
garantiert u. also nicht ratsam.
Was du brauchst ist jedenfalls ein eintrag im etc/fstab. guck dir dort
die vorhandenen Eintraege an.
wie genau das setting fuer read/write zugriff lautet weiss ich nicht
(auswendig), was ich weiss ist
dass du durch uid=useriddeinesBenutzers bestimmen kannst, im gemounteten
laufwerk den owner
der Dateien zu bestimmen - damit das nicht root ist. Dein uid findest du
(u.a.) in deiner passwd Datei.
dann kannst du den mount befehl so schreiben, wie du's unten geschrieben
hast.

das loest zwar nicht alle deine probleme, aber vielleicht kommst du ein
bisschen weiter,

bye,
Federico

Günther Obrist schrieb: