mplayer

Ciao.
Ieri ho installato mplayer e qualche lib: libao, libdvdcss, libdvdread,
libmpeg (compilate, copiate a /usr/lib e poi fatto ldconfig). Volendo guardarmi
poi un divX, mi ha dato il seguente errore:
Linux RTC init: ioctl (rtc_pie_on): Permission denied

MPlayer CVS-011124-06:00(C) 2000-2001 Arpad Gereoffy (see DOCS!)

CPU vendor name: AuthenticAMD max cpuid level: 1
CPU: Advanced Micro Devices Athlon TB Thunderbird
extended cpuid-level: 6
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Reading /home/benj/.mplayer/codecs.conf: 21 audio & 58 video codecs
font: can't open file: /home/benj/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using usleep() timing
Playing American Pie.avi
Detected AVI file format!
MainAVIHeader.dwFlags: (2064) HAS_INDEX TRUST_CKTYPE
VIDEO: [DIV3] 720x432 24bpp 25.00 fps 844.0 kbps (103.0 kbyte/s)
[V] filefmt:3 fourcc:0x33564944 size:720x432 fps:25.00 ftime:=0.0400
Support for win32 codecs disabled, or unavailable on non-x86 platforms!
FATAL: Couldn't initialize video codec :frowning:
Detected audio codec: [mp3] drv:1 (MPEG layer-2, layer-3)
mp3lib: Processor ID: 644
mp3lib: Using AMD 3dnow-dsp(k7)! optimized decore.
AUDIO: srate=48000 chans=2 bps=2 sfmt=0x10 ratio: 16000->192000
Detected video codec: [divx] drv:2 (DivX :wink: (MS MPEG-4 v3))
*** free_stream() called ***

Exiting... (End of file)

Qualcuno sa dove c'`e l'errore o che cosa devo installare ancora?

Saluti da Monaco
Benjamin

mplayer installa le lib in /usr/local/lib per default, io ad esempio ho
aggiunto questo path nella /etc/ld.so.conf

Poi ho scaricato i w32 codex dalla pagina di mplayer e ho creato la
codecs.conf nel ~/.mplayer/. C'è un template nella directory di mplayer,
basta copiare :slight_smile:

Hai fatto tutto questo?

byez
Patrick

ben.j(a)gmx.net wrote:

mplayer installa le lib in /usr/local/lib per default, io ad esempio ho
aggiunto questo path nella /etc/ld.so.conf

Poi ho scaricato i w32 codex dalla pagina di mplayer e ho creato la
codecs.conf nel ~/.mplayer/. C'è un template nella directory di mplayer,
basta copiare :slight_smile:

Reading /home/benj/.mplayer/codecs.conf: 21 audio & 58 video codecs
Support for win32 codecs disabled, or unavailable on non-x86 platforms!
FATAL: Couldn't initialize video codec :frowning:

sembra propio che non ha installato i codici (devi copiarli nella seguente
directory /usr//lib/win32

mfg guggi

Hai fatto tutto questo?

byez
Patrick

ben.j(a)gmx.net wrote:

> Ciao.
> Ieri ho installato mplayer e qualche lib: libao, libdvdcss, libdvdread,
> libmpeg (compilate, copiate a /usr/lib e poi fatto ldconfig). Volendo

guardarmi

Ho aggiunto /usr/local/lib nella /etc/ld.so.conf, per`o non ho scaricato i
codex. Le scarico adesso e riprovo stasera.
Grazie
Benjamin