NextCloud impossibile eliminare file

Ciao a tutti,
ho un problema con NextCloud, non riesco a cancellare un file dalla
cartella locale e nemmeno se mi autentico dal web con https:…

Il messaggio:
Errore durante l'eliminazione dei file "NomeFile"

La cosa strana è che non riesco a cancellarne solo alcuni.

Come potrei risolvere il problema?

Ciao e grazie
andrea

attachment.htm (2.38 KB)

hai già provato a fare un resync nuovo ?
t.

attachment.htm (3.24 KB)

Ciao Anton,

cioè?

Ciao ciao

attachment.htm (7.33 KB)

intendevo: fermare il client - impostare una nuova cartella locale e far ripartire il client ...
( una proposta puramente empirica, che però una volta mi ha risolto le difficoltà )
a presto - fammi sapere se funziona

t. (come toni :slight_smile: sto rivalutando questo nome )

attachment.htm (7.85 KB)

Purtroppo non funziona

Ciao
andrea

attachment.htm (8.58 KB)

nisba, andrea: mi mandi il logfile con le righe di errore ( meglio [ mailto:anton.auer(a)ecolnet.bz | anton.auer(a)ecolnet.bz ] )
t.

attachment.htm (9.06 KB)

Ciao, ieri Anton e Markus mi hanno aiutato a risolvere il problema e li
ringrazio.

Abbiamo (tutto lato server):
1. fatto vedere a Markus il file nextcloud.log dal quale ha ricavato
l'errore
2. messo Nextcloud in manutenzione aggiungendo una riga al file config.php
3. svuotato la tabella oc_file_locks del data base che gestisce Nextcloud
4. commentato la riga del file config.php che mette Nextcloud in
manutenzione

A questo punto ho potuto cancellare file e cartelle bloccati.

Di seguito i dettagli in inglese con due possibili soluzioni, noi
abbiamo usato la prima.

Manually disable locking state:

put Nextcloud in maintenance mode: edit config/config\.php and change

this line:
'maintenance' => true,
Empty table oc_file_locks: Use tools such as phpmyadmin or connect
directly to your database and run (the default table prefix is oc_, this
prefix can be different or even empty):
DELETE FROM oc_file_locks WHERE 1
disable maintenance mode (undo first step).
Make sure your cron-jobs run properly (you admin page tells you when
cron ran the last time):
https://docs.nextcloud.org/server/13/admin_manual/configuration_server/background_jobs_configuration.html
1,0k

Permanent solution (if it happens regularly)

on your own server: Use redis for this feature\. It is faster and so

far no problems have been reported. You can follow the instructions for
memory-caching in the docs:
https://docs.nextcloud.org/server/13/admin_manual/configuration_server/caching_configuration.html#id4
3,3k
Shared hosting (others who can’t install redis): You can disable the
file locking, edit your configuration file config/config.php:
'filelocking.enabled' => false,
However, disabling is not a good solution. You can run into problems
when several processes try to write to a file (especially online editors
in the web-interface). In single-user and single-client environments,
it’s probably less of a problem.

Ciao e grazie
andrea

attachment.htm (7.44 KB)