nvidia & jaunty

Ciao,

dopo aver installato jaunty non riesco + a compilare il driver con il
seguente errore:

ERROR: The CC sanity check failed:

       The C compiler 'cc' does not appear to be able to
       create executables. Please make sure you have
       your Linux distribution's gcc and libc development
       packages installed.

ma ho tutto ok, gcc della stessa versione di quella usata dal kernel .. che
puo' essere ? Non riesco a trovare cosa genera quel problema ...

La cosa mi era andata senza problemi su hardy ...

Ciao,

hai fatto un semplice 'apt-get install nvidia-graphics-drivers-180' o lo fai a mano?

Quando l'ho fatto sul mio portatile funzionava senza problemi (con kubuntu jaunty).

attachment.htm (1.47 KB)

sia a mano che con apt-get ... io pero' ho preso il pacchetto
nvidia-glx-180

      The C compiler 'cc' does not appear to be able to
      create executables. Please make sure you have
      your Linux distribution's gcc and libc development
      packages installed.

Secondo me ti manca qualche pezzo della toolchain di gcc.
Vedrai che non riesci a compilare ed eseguire neanche "hello world".

Se in Debian installi solo gcc ma non il meta pacchetto
build-essentials o qualcosa del genere (troppo pigro per controllare)
ti installa il compilatore nudo e crudo senza dei file essenziali
della libc che poi ti servono per creare l'eseguibile.

Bye,
Chris.

Si hai ragione Chris, ma ho installato anche quello....

stesso errore succede se installo il packetto nvidia-glx-180 ... quindi
secondo me c'e' qualcosa nella neo distribuzione ...

A logica un pacchetto dovrebbe avere tutte le dipendenze giuste!

Io ho avuto problemi (freeze) con il binario nvidia e la jaunty tan'è che ho
dovuto disabilitarlo (ora uso il driver opensource nv).