Partitionen unter Linux

Hallo,

ich bin mit meinem wenigen Latein am Ende.
Man hat mir eine HD in die Hand gegeben, auf der sich eine aeltere Linux
Installation (auch SuSe) befand. Ich sollte die einbauen und komplett neu
beschreiben - mit einer neuen SuSe Version.
Ich habe die HD also eingebaut und gleich von der Installations-CD gebootet.
Beim Setup der Partitionen erschien mir alles richtig zu sein: Root, Swap
und ext. Alle zusammen machten den Umfang der HD aus. Zwar verstand ich
nicht die Nummerierung ab 5 (statt 1), aberich dachte, das Setup wuerde das
schon allein machen.
Nun: Ich kann nicht von HD Linux booten. :-s Irgendwie ist da der MBR
wech... nur warum? Ich kenne mich mit Reiser nicht aus, habe dann versucht
mit FDISK ueber ne Bootdisk reinzukommen, aber FDISK verabschiedet sich mit
blinkendem Cursor gleich nachdem ich "Y" fuer maximalen Speicherplatz
getippt habe.
Mit yast 1 bzw. yast 2 (von CD-ROM) bekomme ich die Linux Installation zum
laufen; ich dachte dann lege ich mal eine Bootdisk an. Aber selbst wenn der
PC von floppy aus startet, wird wieder nach der CD-ROM gefragt und dann
wieder ueber yast, also das KDE sehe ich dann locker nach zehn Minuten 8-s.
Kann ja nicht so gehen.
Ich habe sogar eine zweite Platte montiert (weil ich dachte, wenn ein
Microsoft OS dranhaengt, geht FDISK vielleicht doch), aber nada. No. Nyet.
Same error.
Zum guten Schluss ist mir der Kragen geplatzt und ich habe die Installation
abgeschrieben (soll heissen: ich habe ueber das Control Center saemtliche
Partitionen so veraendert, dass sie FAT sind). Hat auch nichts gebracht.
Da ich eine HD verschossen habe und am Montag mit einer neuen (aber auch
gebrauchten, Win 98 ist drauf) HD ankommen werde, wollte ich fragen, wie ich
die Festplatte "traktieren" muss (wenn ein anderes OS und Dateisystem [FAT]
bereits vorhanden ist), sodass am Ende nur Linux drauf ist.

:confused:

cu
Pasquale

Ciao,
volevo chiedervi una consulenza. Sono in grosse difficoltà nel configurare
una scheda Tv Cinergy 400 della Terratec (sintonizzatore Philips e non Bt848
o 878) sotto linux (RH 7.3 con kernel 2.4.18-3). Sapreste dirmi come fare o
dove posso trovare informazioni utili.
Grazie

hallo

Da ich eine HD verschossen habe und am Montag mit einer neuen (aber auch
gebrauchten, Win 98 ist drauf) HD ankommen werde, wollte ich fragen, wie

ich

die Festplatte "traktieren" muss (wenn ein anderes OS und Dateisystem

[FAT]

bereits vorhanden ist), sodass am Ende nur Linux drauf ist.

ueberschreib z.b mit dd if=/dev/null of=/dev/hdXX die ersten paar bloecke.
du musst das dd irgendwann abbrechen (oder per parameter angeben wieviele
bloecke er schreiben soll) sonst schreibts die ganze platte voll

in den ersten 512 bytes liegt der mbr. wenn du den ueberschreibst weiss kein
os mehr wie die partitionen aussehen und sie ist (fuer das os) praktisch
"unformatiert"
danach solltest du damit normal vorgehen koennen wie sonst immer
wenn du das dd laufen laesst ist die platte danach wirklich "leer" -> alles
\0 drauf
wenns dann immer noch nicht laeuft ist was anderes dran schuld, nicht die
formatierung.

eigentlich sollte das fdisk unter linux aber keine probleme haben mit fat's
und anderen filesystemen

peter

wenns dann immer noch nicht laeuft ist was anderes dran schuld, nicht die
formatierung.

Ich möchte nur daran erinnern, dass Suse 8 meine Festplatte nicht
formatieren konnte, und auch die alten Partitionen nicht erkannt hat.
Ich bin dann halt auf rh umgestiegen und dort hat das partitionieren und
formatieren einwandfrei funktioniert

Martin

Hallo Martin!
Hast du es mit Installation "Manual" auch versucht?
Grüße
Luigi

Hallo...

ich habe heute die 20 GB Platte ausprobiert. Nagelneu Suse Linux
draufgezogen. Soll heißen:
Erst habe ich die Platte im DOS neu formartiert und danach die Partition auf
aktiv gesetzt. Dann habe ich SuSe Linux machen lassen ("gesamte Festplatte
für Linux verwenden").
Nach dem Neustart dasselbe Problem: Linux startet nicht von Festplatte. Ich
habe mit einer DOS Bootdisk und FDISK nachgeschaut: Die Linux Partition war
einfach nicht auf aktiv gesetzt!!! Komischer Fehler, hm? Man sollte
eigentlich annehmen, daß Yast das übernimmt.

Egal, jetzt läuft's halt. :wink:

Gruß
Pasquale

Luigi di Lazzaro schrieb:

Hallo Martin!
Hast du es mit Installation "Manual" auch versucht?
Grüße
Luigi

Habe auch mit fachkundiger Hilfe (TLIP) keine Lösung gefunden

mfg
Martin