php e localhost

Ehm, forse non mi sono spiegato:
sono tre giorni che digito "http://localhost/index.php"\!
Spinto dalla disperazione, avevo poi aperto direttamente il file con
Konqueror ma, come prevedevo, mi ha mostrato il codice sorgente.
Comunque grazie a tutti,
Beppe

P.S.: Mi è stato suggerito di disinstallare e reinstallare Apache e php,
con Yast. L'ho fatto, ma il risultato non cambia.

Ehm, forse non mi sono spiegato:
sono tre giorni che digito "http://localhost/index.php"\!

La tua mail piu` recente infatti non diceva questo...

Spinto dalla disperazione, avevo poi aperto direttamente il file con
Konqueror ma, come prevedevo, mi ha mostrato il codice sorgente.
Comunque grazie a tutti,

Ma, nel frattempo mi e` capitata una SuSE 9.1 professional installata
fresca sotto mano - come altro non aspettavo PHP funziona out of the
box. Bo?

Bye, Chris.

Ciao.

beppebz wrote:

Ehm, forse non mi sono spiegato:
sono tre giorni che digito "http://localhost/index.php"\!
Spinto dalla disperazione, avevo poi aperto direttamente il file con
Konqueror ma, come prevedevo, mi ha mostrato il codice sorgente.
Comunque grazie a tutti,
Beppe

P.S.: Mi è stato suggerito di disinstallare e reinstallare Apache e php,
con Yast. L'ho fatto, ma il risultato non cambia.

Hai verificato che Apache2 carica il modulo php4? Dovresti trovare
qualcosa come
LoadModule php4_module /usr/lib/apache2/modules/libphp4.so
nella /etc/apache2/apache2.conf (oppure /etc/apache2/httpd.conf o
qualcosa di simile - non so dove e con quale nome la SuSE salva il file
di configurazione di apache2).

Saluti,
  Benjamin