PiBakery - The blocks based, easy to use setup tool for Raspberry Pi

Grazie a Marco Ciampa del LinuxTrent per il link.

Paolo.

attachment.htm (172 Bytes)

Approposito, qualcun alto ha problemi a far funzionare l` UART sul Rpi 3?
Sto cercando di stabilire una connessione Modbus RTU 9600 8N2 ma non mi
vuole funzionare. Con Serial to Usb invece si. E se provo UART <=> Serial
to usb pure funziona... Nel config.txt ho impostato enable_uart=1 come
sugerito da altri siti web.. se no non ci starebbe il ttyS0.. Sono
disperato... Ce qualcosa con i symlink /dev/ttyS0 > serial0?

attachment.htm (563 Bytes)

Sto cercando di stabilire una connessione Modbus RTU 9600 8N2 ma
non mi vuole funzionare. Con Serial to Usb invece si.

Hmm, attento che il Raspberry Pi fornisce 0V..3.3V all'uscita della
UART, e non i -12V..12V di un interfaccia seriale [1].

E se provo UART <=> Serial to usb pure funziona...

Interessante. Il tuo convertitore USB-Seriale per caso fa del voltage
detection?

Ce qualcosa con i symlink /dev/ttyS0 > serial0?

Spero proprio di no. I devices sotto Linux vengono identificati tramite
minor e major numbers, non attraverso il loro nome.

tp(a)tplinux:~$ ls -l /dev/ttyS0
crw-rw---- 1 root dialout 4, 64 Sep 12 08:30 /dev/ttyS0
^ ^^^^^

HTH
Thomas

[1] http://elinux.org/RPi_Serial_Connection

Ciao
Ho individuato il problema. Il nuovo pi 3 e` dotato di bluetooth, il quale
usa la seriale principale, e la seriale UART e` attachata a una specie di
miniuart che fa problemi. Quindi al posto di perderci tempo per risolvere
il problema ho preso il pi2 che funziona perfettamente.. :smiley:

2016-09-12 15:41 GMT+02:00 Thomas Pircher <tehpeh-lugbz(a)tty1.net>:

attachment.htm (2.38 KB)