Problema con stampante in rete

Ciao Davide,
Hai fatto anche una prova di cambiare driver, p.e . da PCL a PS o viceversa?
Ciao Markus

attachment.htm (1.34 KB)

Ciao Davide

Spero di esserti di aiuto, ma le stampanti sono sempre una rogna anche se
le hp non dovrebbero avere problemi con linux (se non sono troppo nuove).

1) controlla se trovi i driver su http://www.openprinting.org/printers

2) in alternativa sul supporto hp
http://h10025.www1.hp.com/ewfrf/wc/product?cc=it&lc=it&dlc=it&product=5218810

3) forse devi installare hplip da
http://hplipopensource.com/hplip-web/index.html?
per controllare se è installato
dpkg -l hplip

Ciao Ezio

prof. Ezio Monastero
Gruppo Fuss di supporto alle TIC
Intendenza scolastica in lingua italiana
via del Ronco, 2 Bolzano
cell. 334 6031490

Ciao Davide.
Dalle caratteristiche della 4622 che leggo (HP HP Stampanti) ritengo che stampi solo in PCL3.
Non vi sono opzioni aggiuntive (tipo RAM o emulatori PS). HP afferma la compatibilità con OS Linux e fornisce il supporto, come ti ha indicato Ezio (http://hplipopensource.com/hplip-web/index.html).
Forse qui (http://hplipopensource.com/hplip-web/models/officejet/officejet_4620_series.html) trovi qualche info di dettaglio.

Resta da capire come la hai connessa: WiFi o usb?

Se via wifi: la stampante avrà acquisito un suo ip (o via dhcp o via configurazione fissa); risponde al ping? con un telnet ci arrivi?

ciao ,
diego

Ciao grazie per i suggerimenti.

La stampante è collegato ad un printserver (rasperry) via usb. Il mio pc
si collega al cups di rasperry via remoto (ipp).

In teoria non ci dovrebbero essere problemi perché:

A) già usavo la stampante da mesi in questa configurazione con un
xubuntu 13.10 senza problemi, è stato il passaggio alla xubuntu 14.04
che ha introdotto il problema
B) nella xubuntu 14.04 se collego direttamente con usb funziona
perfettamente, ma se la usa attraverso il printserver allora ho il
problema (ma solo dalla 14.04 non nella versione precedente)

Quindi c'e' qualcosa in questa nuova xubuntu 14.04, tra l'altro
installata nuova (non upgrade) e quindi in teoria "pulita" che da problemi.
Tuttora se faccio il boot dalla 13.10 tutto funziona perfettamente.

Quindi ho hanno introdotto un cambiamento o per sfortuna mi manca
qualche libreria che c'era prima e ora non è più installata.

Quindi in realtà mi servirebbero dei suggerimenti su come debbugare il
problema. Io ho già messo "debug" nel cupsd conf e controllo il suo log
e il syslog
ma non trovo qualcosa che mi aiuti. Ovvero ci sono alcune cosette strane
ma non so se ricongiungerle a questo problema ...

Ci sono altri modi per debbuggare cupsd più in dettaglio? Oppure se
mancano delle librerie o ci sono dei problemi con i permessi?

attachment.htm (3.24 KB)

Ciao,

poi allegare un screenshot della tua config della stampante su cups!

Apri Browser: localhost:631
vai alle stampanti

Hai fatto il share della stampante?

Poi provare: cupsenable queue_name

konrad

Ciao,

grazie per il suggerimento. Alla fine ho risolto. Il problema è che il
messaggio di errore che mi riportava
il cups sul mio portatile era il messaggio di errore che c'era sul
printserver, ecco perché non lo trovavo sulla
mia macchina, ma invece l'ho trovato sul rasperry usando: localhost:631

Grazie a tutti per l'aiuto

Davide ciao.
Per terminare al meglio potresti riassumere il problema, la tua indagine sul RBPi, la soluzione adottata?
Questo potrebbe essere utile ad altri e darebbe soddisfazione a tutti quanti hanno contribuito :wink:

diego

Ciao Diego,

certamente. Il tutto è cominciato quando ho acquistato la stampante
citata e ho scoperto dopo con grande sorpresa che non ha il cavo di rete
come la precedente (ma solo wi-fi e usb). A me interessava avere la
possibilità di condividerla attraverso il cavo di rete.

In linux è possibile collegare la stampante ad un computer e
condividerla in rete con altri computer. Si fa tutto abbastanza
facilmente, è previsto dai wizard.

Solo che collegarla ad un computer in particolare è scomodo, perché quel
computer dovrebbe essere sempre acceso.
Allora ho pensato a RBPi (molto più economico). Quindi ho installato la
raspian (debian), ho collegato la stampante come usb e il cavo di rete.
Poi in raspian ho configurato cups per installare e condividere la
stampante in rete.

Infine da ogni computer basta installare una stampante in rete e puntare
al RBPi e la trova. Per la cronaca il rasperry a volte viene
spento brutalmente, perché collegato all'interrutore centrale insieme
alla stampante e altri dispositivi, cosa che avevo
già parlato in questa lista. Però fino ad ora devo dire che questo ha
mai creato problemi (il journaling funziona :wink:

Il problema si era causato sul RBPi. Probabilmente ho spento la
stampante mentre lui stava cercando di stampare
e cups è andato in "pause". Il problemi con questi pause è che non ne
esce più anche se la stampante torna attiva e
bisogna "riabilitare" la stampante manualmente. Questo succede anche se
la stampante è collegata come usb.

Solo che questo messaggio era forwardato al computer chiamante e quindi
sembrava che il computer chiamante
avesse problemi a stampare ma li non c'era nessun errore che infatti non
trovavo ...

Se vi servono altre info volentieri ...

Saluti

attachment.htm (2.93 KB)