Probleme mit ISDN

Liebe Pinguine,

seit der Installation Party habe ich nun SUSE Linux 7.2 auf meinem PC. Die
Freude ist groß, aber im Augenblick noch durch ein paar geringfügige Mängel
getrübt. Wer kann mir helfen?

Die Probleme sind:
* Es lässt sich keine Verbindung zum Provider herstellen.
* Das OS erkennt anscheinend meinen Drucker nicht, der reagiert
nämlich nicht auf einen Druckbefehl.
* Ist es normal, dass ich PDF-Dateien auf den WIndows-Partitionen von
Linux aus nicht öffnen kann, auf der Linux-Partition hingegen schon?

Vor allem das erste Problem würde ich gerne bald lösen, damit ich Zugang zum
Internet habe. Wer kann mir helfen?

Ich freue mich auf eine Antwort!

Happy trails,
Günther Cologna

Hallo Guenther

Fangen wir mal bei der PDF-Datei an. Wenn du auf der DOS- und auf der
Linuxpartition jedes mal dieselbe Datei (z.B. irgendwas.pdf) mit demselben
Programm (z.B. xpdf) oeffnen willst und und es geht einmal schon und einmal
nicht, dann versteh ich auch nicht, warum es nicht funktioniert. Wenn du aber
dieselbe Datei einmal unter DOS z.B. mit dem Acrobat Reader liest und einmal
unter Linux mit xpdf und es funktioniert mit dem Acrobat Reader und mit xpdf
nicht, dann ist das durchaus moeglich. Warum? Der Acrobat Reader hat von Version
zu Version ein paar neue Eigenschaften bekommen, die sich auch im Format
niedergeschlagen haben, und xpdf kann mit diesen proprietaeren Eigenschaften
nicht immer etwas anfangen. Hast du unter Linux ebenfalls den Acrobat Reader
installiert?

Zum ProviderProblem. Das kann viele Ursachen haben. Versuche das mal genauer zu
erklaeren, bzw. ein paar Punkte zu klaeren:

1. Spricht Linux das Modem an oder nicht?
2. Waehlt das Modem?
3. Beginnen beide Modems eine Kommunikation, koennen aber kein Protokoll
vereinbaren oder so was in dieser Art?

Wenn dein Modem ein schoenes externes Modem ist, dann kannst du mal beobachten,
wie die LEDs laeuchten und ob sich irgendwas tut, ob v.a. die Linie geoeffnet
wird. Dann machst du noch was, du beobchtest die Protokolldatei beim
Einwaehlversuch. Dazu oeffnest du eine Shell beobchtest mit dem Befehl "tail"
die neuen Eintraege in der Datei "/var/log/messages". Das musst du als user root
machen:

    tail -f /var/log/messages

Du kannst dir das auch protokollieren lassen, z.B. so:

     tail -f /var/log/messages | tee ~/messagesprot.txt

Dann macht tail dasselbe wie vorher, uebergibt die Ausgabe dem tee und das
schreibt sie dann zum einen in die Shell und zum anderen in die angegebene
Datei, in diesem Fall in die Datei messages_prot.txt im Homeverzeichnis des
gerade angemeldeten Benutzers (also root).

Wenn dabei nicht viel rauskommt, dan kannst du versuchen in der Datei
/etc/ppp/options eine weitere Option hinzuzufuegen: haeng mit einem Editor die
Option "debug" in eine neue Zeile mit dazu. Wenn du mit all diesen Infos die
Ursache nicht erkennst, dann schau mal beim Provider nach, vielleicht hat der
Infos zu Linux auf seiner Seite. Ud schick uns dann bitte die Eintraege in die
Datei /var/log/messages und die der Datei /etc/ppp/options beim naechsten
Posting mit. Schreib uns bitte auch, wie und mit welchen Instrumenten du dich
ins Internet einwaehlst.

All dies waren Tipps, die ich hier mal niedergeschrieben haben, oohne jemals
Suse gesehen zu haben, also Suse-Leute, meldet euch, v.a. die, die die
Installation unterstuetzt haben, dann koennen wir das schon klaeren.

Zum Drucker? Welchen Drucker hast du, was hast du schon versucht? wenn du
druckst, bekommst du eine Fehlermeldung? Was benutzt du zum Drucken? Schau mal
mit dem Befehl "lpq", ob ueberhaupt was in die Warteschlange kommt. Mit welcher
SW hast du versucht zu drucken? Versuch mal eine kleine Textdatei zu drucken:

    lpr Datei.txt

und dann versuch es mit einer kleinen Postscriptdatei

    lpr Datei.ps

Du hast keine Postscriptdatei? Dann oeffne mit Netscape ein kleines File und
sage dann SAVE AS und gib als Datei Postscript an, dann hast du eine.

Servus
Karl

Karl eine Frage, benutzt man bei ISDN auch ppp, ist da nicht ISDN-CTRL
und solche Sachen einzusetzen, ich habe niemals ISDN benutzt aber dachte
ppp sei für analoge modems.

byez pazzo

karl(a)lunger.org wrote:

Patrick Ohnewein wrote:

Karl eine Frage, benutzt man bei ISDN auch ppp, ist da nicht ISDN-CTRL
und solche Sachen einzusetzen, ich habe niemals ISDN benutzt aber dachte
ppp sei für analoge modems.

Haengt vom Modem ab. Bei einem internen Modem kann das schon stimmen, das externe Elsa
der Schule spreche ich normal mit AT-Befehlen an. Mit so Karten hab ich keine
Erfahrung. Wird das mit isdn4linux gemacht?

Guenther, was hast du denn in deinem PC? Wer hat dir bei der Installation geholfen?

Karl

Dies könnte eine gute Hilfe sein!

Hat dir Andreas geholfen? Der wird noch arbeiten.

byez pazzo

karl(a)lunger.org wrote:

Patrick Ohnewein wrote:
> Karl eine Frage, benutzt man bei ISDN auch ppp, ist da nicht ISDN-CTRL
> und solche Sachen einzusetzen, ich habe niemals ISDN benutzt aber dachte
> ppp sei für analoge modems.

Haengt vom Modem ab. Bei einem internen Modem kann das schon stimmen, das
externe Elsa der Schule spreche ich normal mit AT-Befehlen an. Mit so
Karten hab ich keine Erfahrung. Wird das mit isdn4linux gemacht?

Guenther, was hast du denn in deinem PC? Wer hat dir bei der Installation
geholfen?

Karl

Soviel ich weis hat der Günther eine AVM-Fritz PCI installiert
Die ist ganz einfach (wenn die nötigen Module compilert wurden) zu
konfiguriren.
Falls du den SuSe-Kernel benutzt haben die von SuSe schon einen Großteil der
Arbeit gemacht, und das nehme ich jetzt einfach mal an.
Dann brauchst du nichts anderes zu machen als yast zu starten
und unter Administration des Systems, Hardware in System integrieren, ISDN
Karte zu wählen. Dort kreutzt du dann ISDN4Linux an und wählst die
entsprechende ISDN-Karte (Fritz-PCI) dann wählst du einfach mal starten aus.
Wenn alles gut geht mault der yast nix und die Karte ist fast einsatzbereit.
Danach noch Netzwerk konfigurieren Netzwerkgrundkonfiguration. Dort musst du
ein Device für deine ISDN-Karte anlegen. Das geschieht mit F5, dann wählst du
Syncppp mit F6 eine IP-Adresse angeben z.B. 192.168.1.99 und zum schluß noch
mit F4 aktivieren. Zuallerallerletzt mit F8 die Konigurationsdaten für deinen
Provider eingeben PUNKT :slight_smile:

Wenn alles glatt gegangen ist kannst jetzt mal versuchen zu wählen z.B. mit
isdnctr dial ippp0, danach mit imon schnell kontrollieren ob du eine
Verbindung aufbaust. Bei erfolg kannst du dich mit isdnctrl hangup ippp0
wieder trennen.

Viel Glück, bei mir hatts zwei Wochen gedauert bis das Sch...öne Modem
funktionert hat.

mfg guggi