Problemi con VNC

Ciao a tutti.
Da qualche giorno (infatti, da quando si è provato di installare qualche
font) ho problemi con il server VNC.
Attacco il logfile a questa mail.
Qualcuno sa cosa potrebbe essere il problema?

~~benjamin

vnc.log (948 Bytes)

Bè scheint als hättest du ein problem mit den Font-Paths:

failed to set default font path
'/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/'

>> Gibt es die angegebenen Pfade und hat der X-Server die Rechte
zuzugreifen?

Scheint als hättest du fixed Fonts als default, und die sollte es nun
wirklich geben :slight_smile:
>> could not open default font 'fixed'

Dies scheinen nur Folgefehler zu sein.
>> xrdb: Connection refused
>> xrdb: Can't open display 'testlinux:1'
>> xsetroot: unable to open display 'testlinux:1'
>> twm: unable to open display "testlinux:1"
>> xterm Xt error: Can't open display: testlinux:1

Funktioniert X, von lokal also nicht über VNC?

byez
Patrick

ben.j(a)gmx.net wrote:

Die Pfade existieren alle und haben mindestens die Berechtigung 444
(Besitzer root).
X lokal funktioniert, ich weiß aber nicht ob Andreas es seit dem
Installieren der Schriften einmal neu gestartet hat - diese Woche hat er frei
genommen...

~~benj

Bè scheint als hättest du ein problem mit den Font-Paths:

failed to set default font path

'/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/'

Ma ich habe nun auch probleme mit VNC :slight_smile:

Eigentlich nicht direkt mit VNC aber mit dem GDM, den ich benutzen um
einen schönen login screen zu präsentieren.

[root(a)linux gdm]# tail /var/gdm/linux.prodata.it\:1.log
Xlib: connection to "linux.prodata.it:1.0" refused by server
Xlib: Client is not authorized to connect to Server
Xlib: connection to "linux.prodata.it:1.0" refused by server
Xlib: Client is not authorized to connect to Server
Xlib: connection to "linux.prodata.it:1.0" refused by server
Xlib: Client is not authorized to connect to Server
Xlib: connection to "linux.prodata.it:1.0" refused by server
Xlib: Client is not authorized to connect to Server
Xlib: connection to "linux.prodata.it:1.0" refused by server
Xlib: Client is not authorized to connect to Server

hmmm. Und ich habe keine ahnung warum ab heute das nicht mehr
funktioniert, es ist zu mittag der strom ausgefallen und nach dem
neustart funkts nicht mehr. Entweder der Stromausfall (unwahrscheinlich)
oder irgend eine lib die ich aktualisiert habe (wahrscheinlicher) ist
schuld.

Aber zu dein Problem, hast du physischen zugriff auf den rechner? Hast
du daher direkt am rechner überprüft ob X wirklich noch funktioniert?

Wie startest du XVNC server? Über inetd (xinetd) oder händisch
"vncserver :2" ?

byez
Patrick

Inzwischen läuft der Server: ich habe den Schriftpfad manuell als Parameter
von Xvnc angegeben (im schönen Startscript vom VNC-Server...)
Den Server starte ich manuell über eine SSH - Verbindung (es grüßt puTTY).
Jetzt könnte ich endlich mit Andi chatten, wenn er nicht im Urlaub wäre
:-(((

zu deinem Problem: hast du probiert, mit xauth die Berechtigungen zum
Zugriff auf den X-Server zu geben?

~~benj

slve ragazzi, io uso vnc ma non posso aiutarvi perche' capisco poco del
problema ;))))

        ByeZ

                Andy

Hmmm habe mit dem xauth nicht viel erfahrung und möchte es auch nicht
darauf ankommen lassen :slight_smile:

Nein es hat bis heute funktioniert und shit, ich verstehe nicht warum
der anfängt so dumm zu tun!?

Gut wenns sein muss, hast du ne ahnung von xauth?

Ich habe gesehen dass in den home verzeichnisse der user eine datei
namens .Xauthority existiert und da sind die MAGIC_COOKIES enthalten,
some sort of public key I guess. Aber da ist mein Latein schon bald an
dessen Ende angelangt. Also was ich nicht ganz verstehe, brauche ich
dies für jeden Benutzer? Muss dies händisch vom Admin (named root)
amministriert werden? Denke wohl eher nicht, da es ja schon einmal
automagicaly funktioniert hat.

Zusätzlich benutze ich vncserver über xinetd, falls ich es manuell
starte funktioniert es. Aber über xinetd müsste nicht eine X-Session
eines bestimmten Users gestartet werden, sondern eine gdm login session.
Xvnc wird mit den dafür geeigneten Parameter mit UID nobody pro Anfrage
am definierten Port gestartet. Leider bekomme ich nur einen grauen
Screen. Dies da gdm nicht starten kann, wie aus den logs ersichtlich.
Nur warum startet er nicht, hmmm...

Hat jemand ne idee?

byez
Patrick

p.s. warum chattest du nicht auf IRC?
p.s.s. #define _IRC_SERVER "irc.discussioni.org" \\#define _CHANNEL "#lugbz"

ben.j(a)gmx.net wrote: