problemi di configurazione della rete/router

Norman Erik (Student Com02) wrote:

Ciao,

Ho incontrato qualche problema con linux e (suppongo!) il pmtu
discovery... Recentemente, a casa abbiamo installato una rete locale
con modem/router/firewall e (fino a) quattro pc collegati (che
costituiscono la rete locale).

Ho configurato l'indirizzo IP del mio PC correttamente (prima Linux
stentava ad andare), ma ho scoperto un altro problema...

Ho scoperto che certi siti (p.es. microsoftupdate.com, yahoo.it ->
giochi ecc.) non andavano piú, ne su Windows XP, ne su RH 9.0.

Ho interpellato il tizio che c'ha venduto il router, e lui m'ha
mandato un eseguibile (ovviamente Windows :expressionless: ), e semplicemente
attivando il path mtu discovery ha funzionato per il lato windows...

MA: non funziona ancora sul lato Linux..

Ho provato ad avviare/disattivare il ptmu in
/proc/sys/ipv4/net/ip_no_ptmu_disc (o simile) ma senza risultato...
Non é servito a niente abbassare il mtu con il commando

ifconfig eth0 192.168.1.11 mtu 1492 (o altri valori, non funziona
niente),

ma non c'é verso...

Ciao Norman.

Così su due piedi non so come aiutarti.

- Esattamente che tipo di router hai?
- Come l'hai configurato?

Ti consiglio di mandare la mail non solo a me ma anche al LUGBZ.
Se non sei gia' iscritto, iscriviti alla mailing list su
http://www.lugbz.org.

Cerca di essere il piu' preciso possibile nella descrizione del
problema, delle configurazioni che hai fatto e degli eventuali messaggi
d'errore.

Ciao,
Paolo.

PS:

Ho guardato come si chiama il router: draytek vigor2600,
la configurazione del router viene gestito da applicazioni windows :expressionless:
non riesco a vedere i parametri..., non da qui...

Visto che non ho ottenuto nessun risultato cambiando le configurazioni
dell'mtu e pmtu discovery, li ho rimessi al valore originale
(mtu=1500 e pmtu attivato (credo))

Erik