problemi di configurazione dell'mtu e pmtu disc

Ciao,

Ho incontrato qualche problema con linux e (suppongo!) il pmtu
discovery... Recentemente, a casa abbiamo installato una rete locale
con modem/router/firewall e (fino a) quattro pc collegati (che
costituiscono la rete locale).
Ho configurato l'indirizzo IP del mio PC correttamente (prima Linux
stentava ad andare), ma ho scoperto un altro problema...
Ho scoperto che certi siti (p.es. microsoftupdate.com, yahoo.it ->
giochi ecc.) non andavano piú, ne su Windows XP, ne su RH 9.0.
Ho interpellato il tizio che c'ha venduto il router, e lui m'ha
mandato un eseguibile (ovviamente Windows :expressionless: ), e semplicemente
attivando il path mtu discovery ha funzionato per il lato windows...
MA: non funziona ancora sul lato Linux..
Ho provato ad avviare/disattivare il ptmu in
/proc/sys/ipv4/net/ip_no_ptmu_disc (o simile) ma senza risultato...
Non é servito a niente abbassare il mtu con il commando
ifconfig eth0 192.168.1.11 mtu 1492 (o altri valori, non funziona
niente),
ma non c'é verso...

Ho guardato come si chiama il router: draytek vigor2600,
la configurazione del router viene gestito da applicazioni windows :expressionless:
non riesco a vedere i parametri..., non da qui...

Visto che non ho ottenuto nessun risultato cambiando le configurazioni
dell'mtu e pmtu discovery, li ho rimessi al valore originale
(mtu=1500 e pmtu attivato (credo))

Erik

* Erik Norman (erik.norman(a)gmx.net) wrote:

Visto che non ho ottenuto nessun risultato cambiando le configurazioni
dell'mtu e pmtu discovery, li ho rimessi al valore originale
(mtu=1500 e pmtu attivato (credo))

Controlla anche /proc/sys/net/ipv4/tcp_ecn.

Ciao Michele,

/proc/sys/net/ipv4/tcp_en ha il valore 0.

devo metterlo ad 1?

e gli altri valori (pmtu_disc, mtu ecc?)

Grazie,

Erik