problemi freeciv

salve a tutti
Sto cercando di usare freeciv (in locale), ma il client non riesce a trovare
la rete. A quanto pare dovrebbe collegarsi a localhost sulla porta 5555. Ma
non ci riesce.

Sul pc (Mandrake 7.2) ho installato anche guarddog (firewall); pensavo che i
problemi venissero da la, e ho provato a disabilitarlo, ma non cambia niente.

Sulla FAQ di freeciv ho scoperto che:

" Come comportamento predefinito il vostro server è disponibile all'host
localhost, porta 5555, indirizzo e porta usati anche dal vostro client. In
questo modo state usando l'interfaccia detta ­loopback­, una connessione di
rete fittizia al vostro computer che può essere usata anche su computer
isolati. In effetti dovrebbe esserci ma esiste almeno una distribuzione di
Linux che non la installa.

localhost dovrebbe essere il nome per l'indirizzo IP 127.0.0.1; su alcune
varianti di Unix questo viene normalmente definito nel file /etc>hosts. Se le
cose stanno effettivamente così assicuratevi che 127.0.0.1 stia
effettivamente funzionando: se state usando una variante Unix provate questi
comandi ifconfig -a
    ping 127.0.0.1
    
Il primo comando dovrebbe mostrare una lista di interfacce di rete con
indirizzo di rete 127.0.0.1 mentre il secondo comando dovrebbe restituire un
errore."

in effetti il mio pc dice:
lo Link encap:Local Loopback
  LOOPBACK MTU:3294 Metric:1
  RX packets:0 errors:0 dropped:0 overruns:0 frame:0
  TX packets:0 errors:0 dropped:0 overruns:0 frame:0
  collisions:0 txqueuelen:0

mentre con ping mi dice network unrachable,

In /etc/hosts l'indirizzo di localhost è 127.0.0.1

Ho provato anche a vedere con host, (host 127.0.0.1) e mi dice host not found

insomma, questa loopback (qualsiasi cosa sia) ce l'ho o non ce l'ho?
e nel caso, come faccio a farla funzionare? Ho voglia di giocare a freeciv

Grazie molte per l'aiuto pfietenk Moe
buon ferragosto
p.s.
per l'amministratore: sono Paolo Möseneder

moe(a)dnet.it wrote:

in effetti il mio pc dice:
lo Link encap:Local Loopback
  LOOPBACK MTU:3294 Metric:1
  RX packets:0 errors:0 dropped:0 overruns:0 frame:0
  TX packets:0 errors:0 dropped:0 overruns:0 frame:0
  collisions:0 txqueuelen:0

Be manca una riga di output e proprio quella col IP e netmask assegnata,
il mio output:
lo Link encap:Local Loopback
           inet addr:127.0.0.1 Mask:255.0.0.0
           UP LOOPBACK RUNNING MTU:3924 Metric:1
           RX packets:9155791 errors:0 dropped:0 overruns:0 frame:0
           TX packets:9155791 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:0

E manca l'UP, penso che devi attivare l'interface.

Fai sulla cons come root:
$ ifconfig lo up
e poi dovrebbe funzionare.

Non so come lo si può far persistente, dovresti leggere un po su
internet, puoi anche usare docu della red hat, perchè la mandrake è un
derivato.

byez pazzo