RE: [Lugbz-list] Ola'

Ora, la cosa non mi da fastidio (non uso
mai le lettere accentate), ma se volessi evitare che accada,
conoscete qualche metodo per sistemare la cosa, oltre ad
editarmi /etc/termcap (e/o
/etc/sysconfig/console/default.kmap) a mano?

Prova a seguire le seguenti istruzioni:

Nel ~/.bashrc (o ~/.bash_profile o ~/.profile) metti:
    export LC_CTYPE=ISO-8859-1

Nel ~/.inputrc
    set meta-flag on
    set convert-meta off
    set output-meta on

Riapri il terminale e dimmi come va.

Tratto dal German-HOWTO. Di seguito un excerpt:

Bye,
Paolo.

Dongilli Paolo wrote:

> Ora, la cosa non mi da fastidio (non uso
> mai le lettere accentate), ma se volessi evitare che accada,
> conoscete qualche metodo per sistemare la cosa, oltre ad
> editarmi /etc/termcap (e/o
> /etc/sysconfig/console/default.kmap) a mano?

Prova a seguire le seguenti istruzioni:

Nel ~/.bashrc (o ~/.bash_profile o ~/.profile) metti:
    export LC_CTYPE=ISO-8859-1

Nel ~/.inputrc
    set meta-flag on
    set convert-meta off
    set output-meta on

Riapri il terminale e dimmi come va.

Non funziona :expressionless:
Pero' per ora ho scoperto che e' 'colpa' di X Windows, per cui andro' a
scartabellare le varie directory di Xfree4.

Per quanto riguarda la patch di cui diceva Chris, non l' ho ancora
cercata. Provero' lunedi' dall' Uni.

Stefano

Che tastiera hai configurato in
/etc/X11/XF86Config
o in
/etc/X11/XF86Config-4 (se usi XFree versione 4)
?

Un estratto dalla mia XF86Config-4, uso tastiera tedesca!
Non uso l'optione nodeadkes, perchè senò non mi funzionano le è italiane
sulla tastiera tedesca, spero ti aiuti!

Section "InputDevice"
         Identifier "Keyboard0"
         Driver "keyboard"
         Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
EndSection

byez
Patrick

Un estratto dalla mia XF86Config-4, uso tastiera tedesca!
Non uso l'optione nodeadkes, perchè senò non mi funzionano le è italiane
sulla tastiera tedesca, spero ti aiuti!

Section "InputDevice"
         Identifier "Keyboard0"
         Driver "keyboard"
         Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
EndSection

Penso che lui abbia bisogno proprio della "nodeadkeys", che per la "it"
non sembra esistere...

Chris.

Se è solo un problema sotto X allora probabilmente è da configurare lì.
Non c'è nessuno con tastiera italiana, non è possibile!
Paolo posta la sezione InputDevive della tua XF86Config(-4)!

Forse prova con un altro term, che con gnome-terminal (se usi quello) ho
avuto dei problemi anchio una volta, prova xterm!

byez
Patrick

chrism(a)desk.nl wrote:

Patrick Ohnewein wrote:

Se è solo un problema sotto X allora probabilmente è da configurare lì.
Non c'è nessuno con tastiera italiana, non è possibile!
Paolo posta la sezione InputDevive della tua XF86Config(-4)!

Forse prova con un altro term, che con gnome-terminal (se usi quello) ho
avuto dei problemi anchio una volta, prova xterm!

Allora, dopo un paio di tentativi, ho scoperto un paio di cose.
Il problema si verifica solo sotto X, ed ecco il mio XF86Config-4:
Section "InputDevice"

    Identifier "Keyboard1"
    Driver "Keyboard"
    Option "AutoRepeat" "250 30"
    Option "XkbRules" "xfree86"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "it"

# Option "XkbVariant" "nodeadkeys"
EndSection

Ho provato diverse opzioni a "XkbLayout", ho provato 'de' e pare
funzionare tutto bene, tranne per il fatto che alla deutsche tastatur
non sono abituato e mi perdo! =)
Per quanto riguarda la 'it', ho provato tutte le tastiere presenti in
/usr/share/kbd ecc ecc, non ricordo il path esato, ma nessuna di queste
sembra funzionare, nemmeno con l' opzione nodeadkeys attivata. In questi
casi riesco si' a scrivere le ò eccetera, ma non mi funzionano piu' @ e
#!!!
La soluzione peggiore pero' (e spero non me ne voglia) e' quella
suggeritami da... Paolo! Mi scombussola tutto il tastiero degli home
end, non mi riconosce le ò e neanche le @ # !!! Appena lo vedo all' Uni
gliene dico 4!! =)

Beh, scherzi a parte, vi ringrazio per l' aiuto, ma penso che mi terro'
i miei caratteri strani: sto vedendo caratteri strani anche sulle pareti
della mia stanza ormai.... forse e' meglio sospendere i tentativi per un
po'... =)

Stefano