redhat 7.2 - problema con chipset gfx sis 630

salve,

ho un "piccolo" problema con REDHAT linux v7.2 installato su un laptop
noname. non riesco a far funzionare xwindows, perchè x non è in grado
di usare la scheda gfx con chipset SiS 630.
(16MB di shared memory, bios v2.02.3b)

sotto win2k funziona perfettamente (1024*768*16M)

qualcuno mi può dare una mano a farlo funzionare?
grazie!

saluti

egon

ps: btw, non sono un esperto linux... :slight_smile:

* egon pramstrahler (egon(a)pramstrahler.it) wrote:

ho un "piccolo" problema con REDHAT linux v7.2 installato su un laptop
noname. non riesco a far funzionare xwindows, perchè x non è in grado
di usare la scheda gfx con chipset SiS 630.
(16MB di shared memory, bios v2.02.3b)

Il codice per sis 630 e' piuttosto nuovo in XFree-4.1.x. L'unica opzione
e' provare ad usare XFree-3.3.6 [Xconfigurator --preferxf3] oppure
installare XFree-4.2.0 [mossa consigliata se si ha un filo di esperienza
ftp://people.redhat.com/mharris/testing/bleeding-edge/XFree86/\]

Salud,
Michele.

ho un "piccolo" problema con REDHAT linux v7.2 installato su un laptop
noname. non riesco a far funzionare xwindows,

Xwindow... non Xwindows :slight_smile:

perchè x non è in grado

di usare la scheda gfx con chipset SiS 630.
(16MB di shared memory, bios v2.02.3b)

mmmm...prova con "setup" a scegliere video e scheda corretti,
eventualmente se non c'è proprio la tua scheda prova a farla funzionare
con una simile della stessa marca che magari usano lo stesso driver (io
lo avevo fatto sul pentium e la Debian per la scheda audio e ha funz).
Altrimenti anche xf86cfg -textmode o xf86config sono ottimi programmi per
la configurazione; devi essere però sicuro che i drivers siano stati
installati; io ho una S3virge e ho avuto bisogno di XFree86-S3V-3.3.6-35;
dovresti controllare a quale tra i pacchetti fa riferimento la tua scheda;
Se hai xrpm basta che installi i pacchetti e fai "query" ma penso che
anche via testo tu possa fare una query per vedere quali schede sono
supportate da quel pacchetto.

sotto win2k funziona perfettamente (1024*768*16M)

già ma se non funziona qualcosa sotto unix nella maggior parte dei casi,
se si sa dove mettere le mani il problema lo si risolve mentre se il "plu
and pray" non funziona sotto winzozz si resta nel letame!

qualcuno mi può dare una mano a farlo funzionare?

Spero io :wink:

ps: btw, non sono un esperto linux... :slight_smile:

pochi lo sono veramente credo :slight_smile: