rpm funktioniert nicht...

Hallo!

Ich habe auf einem RedHat 6.2 ein paar pakete zu
installieren. Um diese pakete installieren zu können habe
ich ein neueres rpm installiert (4.0). Jetzt habe ich aber
das Problem, dass die libraries nicht mehr gefunden werden:
zB: lib.so.6
Diese Libraries sind aber installiert ( /lib/lib.so.6 )
Es werden noch viele andere Pakete gesucht und nicht
gefunden.

Danke!
  dreadhead

Probier a mol ldconfig aufzuruafn.

byez
Patrick

michael.zanetti(a)rolmail.net wrote:

funzt leider a net...

* michael.zanetti(a)rolmail.net (michael.zanetti(a)rolmail.net) wrote:

Hallo!

Ich habe auf einem RedHat 6.2 ein paar pakete zu
installieren. Um diese pakete installieren zu können habe
ich ein neueres rpm installiert (4.0). Jetzt habe ich aber
das Problem, dass die libraries nicht mehr gefunden werden:
zB: lib.so.6
Diese Libraries sind aber installiert ( /lib/lib.so.6 )
Es werden noch viele andere Pakete gesucht und nicht
gefunden.

Und wie hast du genau diesen Upgrade gemacht ?

Bestens du benutzt folgende RPMS fuer 6.x :
ftp://people.redhat.com/jbj/rpm-4.0.4-6x/

Ciao,
Michele

Und wie hast du genau diesen Upgrade gemacht ?

rpm -U rpm-4.0.blabla

Bestens du benutzt folgende RPMS fuer 6.x :
ftp://people.redhat.com/jbj/rpm-4.0.4-6x/

Ich habe schon diese benutzt...

bye
  dreadhead

* michael.zanetti(a)rolmail.net (michael.zanetti(a)rolmail.net) wrote:

> Und wie hast du genau diesen Upgrade gemacht ?
rpm -U rpm-4.0.blabla
> Bestens du benutzt folgende RPMS fuer 6.x :
> ftp://people.redhat.com/jbj/rpm-4.0.4-6x/
Ich habe schon diese benutzt...

rpm --rebuilddb
rpm -Uvh rpm-4.0.4-6x.21.i386.rpm popt-1.6.4-6x.21.i386.rpm
rpm --rebuilddb

Der erste --rebuilddb bist sicher das der db ok ist, und mit dem zweiten
machst den sprung von db1 zu db3