SCSI CD Brenner und cdrecord

Hallo,

ich bin einem Problem auf der Spur und finde leider keine Lösung.

Ich habe einen neuen Debian Kernel (2.4.22) kompiliert und seitdem
findet cdrecord meinen SCSI Brenner nicht mehr. Im Kernel habe ich die
SCSI Module SD, SR und SG fest eingebaut, dazu auch das ide-scsi Modul
für das IDE CD-Rom Laufwerk.

Ein cdrecord -scanbus liefert folgendes:

Cdrecord-Clone 2.01a19 (i686-pc-linux-gnu) Copyright (C) 1995-2003 Jörg
Schilling
Linux sg driver version: 3.1.25
Using libscg version 'schily-0.7'
scsibus0:
        0,0,0 0) *
        0,1,0 1) *
        0,2,0 2) *
        0,3,0 3) *
        0,4,0 4) 'IBM ' 'DDRS-39130 ' 'S97B' Disk
        0,5,0 5) *
        0,6,0 6) *
        0,7,0 7) *
scsibus1:
cdrecord.mmap: Warning: controller returns wrong size for CD
capabilities page.
        1,0,0 100) 'ASUS ' 'CD-S500/A ' '3.3H' Removable
CD-ROM
        1,1,0 101) *
        1,2,0 102) *
        1,3,0 103) *
        1,4,0 104) *
        1,5,0 105) *
        1,6,0 106) *
        1,7,0 107) *

Ein cat /proc/scsi/scsi zeigt aber alle Geräte ordnungsgemäß an:

Attached devices:
Host: scsi0 Channel: 00 Id: 04 Lun: 00
  Vendor: IBM Model: DDRS-39130 Rev: S97B
  Type: Direct-Access ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 05 Lun: 00
  Vendor: PLEXTOR Model: CD-R PX-R820T Rev: 1.08
  Type: CD-ROM ANSI SCSI revision: 02
Host: scsi1 Channel: 00 Id: 00 Lun: 00
  Vendor: ASUS Model: CD-S500/A Rev: 3.3H
  Type: CD-ROM ANSI SCSI revision: 02

Auch cat /proc/sys/dev/cdrom/info zeigt beide Geräte an:

CD-ROM information, Id: cdrom.c 3.12 2000/10/18

drive name: sr1 sr0
drive speed: 50 20
drive # of slots: 1 1
Can close tray: 1 1
Can open tray: 1 1
Can lock tray: 1 1
Can change speed: 1 1
Can select disk: 0 0
Can read multisession: 1 1
Can read MCN: 1 1
Reports media changed: 1 1
Can play audio: 1 1
Can write CD-R: 0 1
Can write CD-RW: 0 0
Can read DVD: 0 0
Can write DVD-R: 0 0
Can write DVD-RAM: 0 0

Ich hoffe jemand kann mir einen Tipp geben woran es liegen könnte.

Markus

* Markus Mitterhofer (markus(a)grimmhof.com) wrote:

Ich habe einen neuen Debian Kernel (2.4.22) kompiliert und seitdem
findet cdrecord meinen SCSI Brenner nicht mehr. Im Kernel habe ich die
SCSI Module SD, SR und SG fest eingebaut, dazu auch das ide-scsi Modul
für das IDE CD-Rom Laufwerk.

Vielleich sind ide-cd u/o cdrom module geladet ?
Wenn du diese unbedingt brauchst must du ein ignore-string als Parameter
zugeben.

Hallo Michele,

danke für deine Antwort.

Vielleich sind ide-cd u/o cdrom module geladet ?
Wenn du diese unbedingt brauchst must du ein ignore-string als
Parameter zugeben.

Nein, das ide-cd Modul ist nicht geladen. Um meine gestrige mail noch zu
ergänzen: Ich kann vom CD Brenner lesen (als /dev/scd0), nur schreiben
(cdrecord benutzt da /dev/sg*, richtig?) geht nicht.

Markus Mitterhofer wrote:

Nein, das ide-cd Modul ist nicht geladen. Um meine gestrige mail noch zu
ergänzen: Ich kann vom CD Brenner lesen (als /dev/scd0), nur schreiben
(cdrecord benutzt da /dev/sg*, richtig?) geht nicht.

Hallo

Ich benutze da

    cdrecord dev=0,0,0 ... -v speed=2 -data iso-file

also die Ausgabe von

    cdrecord -scanbus

Das muesste ab wohl dasselbe sein, oder?

Was passiert nach einem

    cdrecord -reset

Und aendert die Option -force auch nichts?

Werden beim alten und beim neuen Kernel die gleichen Module geladen?

Werden beim alten und beim neuen Kernel die gleichen Module geladen?

Mit den Kernelmodulen war alles in Ordnung. Wie ich vermutet hatte
stimmte etwas mit den /dev/sg* Dateien nicht. Sie waren zwar vorhanden,
haben aber wahrscheinlich mit dem neuen Kernel nicht funktioniert.
Im CD-Writing HOWTO habe ich folgendes gefunden und ausprobiert:

      cd /dev/
       umask -S u=rwx,g=rwx,o-rwx
       [ -f loop0 ] \
           >> ./MAKEDEV loop \
           >> for i in 0 1 2 3 4 5 6 7; do mknod loop$i b 7 $i; done
       [ -f sg0 -o -f sga ] \
           >> ./MAKEDEV sg \
           >> for i in 0 1 2 3 4 5 6 7; do mknod sg$i c 21 $i; done

Jetzt lässt sich der Brenner über cdrecord ansprechen.

Danke für die guten Tipps.

Markus