Ubuntu e OpenC6

Ciao a tutti,

sono alle prese con Ubuntu 5.04, appena appena installata... Carina!

Ora però vorrei installare Openc6 ( http://openc6.sourceforge.net/ ),
ho scaricato (da
http://sourceforge.net/project/showfiles.php?group_id=75082&package_id=75474&release_id=321974
) il "openc6-0.9.7.tar.gz", ma una volta estratto e lanciato il
./configure mi da (verso la fine credo) un bel
"checking for X... configure: error: Can't find X includes. Please
check your installation and add the correct paths!"

Che può essere? Qualche idea?

Provando invece a installare il .deb mi da un bel po' di versioni
invalide per le librerie... (e magari non è nemmeno la soluzione
giusta)

Grazie,

Andrea

Ciao,

Non fai prima con apt-get install ?

Erik

) il "openc6-0.9.7.tar.gz", ma una volta estratto e lanciato il
./configure mi da (verso la fine credo) un bel
"checking for X... configure: error: Can't find X includes. Please
check your installation and add the correct paths!"

Che può essere? Qualche idea?

Non hai tutti i pacchetti di sviluppo installato. Normalmente
la Ubuntu - avendo il desktop come obiettivo - non li installa.

Oltre che a gcc (che a quanto sembra hai gia`) ti servono varie
librerie da sviluppo, sono i pacchetti che hanno nel nome "dev"
o "devel" che sta per "development).

Provando invece a installare il .deb mi da un bel po' di versioni
invalide per le librerie... (e magari non è nemmeno la soluzione
giusta)

Quel .deb sara` stato fatto per un'altra distribuzione che usa
quel formato per i pacchetti (Debian, suppongo).

Bye, Chris.

se sei in ambiente ubuntu, ti consiglio di usare prima i pacchetti
universe ( e - meno consigliato - anche multiverse ), prima di andare
verso installazioni senya rete di sicurezza ( tar.gz ... ./configure ).

molto consigliato: ubuntu starters guide e http://www.ubuntuitalia.it/
per trovare documentazione/aiuto.

anton

Andrea Girardello <andrea.girardello(a)gmail.com> schreibt:

O potrebbe essere che è stato fatto per xfree86?
Ubuntu 5.04 usa però Xorg. Se è così dovresti sostituire xorg con
xfree86.

Ciao
Robert