Unmountable boot volume ?!

Ciao a tutti.
Situazione: 1 HD da 160 con due partizioni:vfat e ntfs; 1 secondo HD con
due partizioni, una delle quali occupata da SuSE10.1;
fino a sabato all'accensione partiva grub che mi dava la possibilità di
usare SuSE (di default) oppure Win.
Se sceglievo Win partiva il boot.ini che mi chiedeva se usare 98 (che
non uso mai) oppure XP.
Adesso non ho cambiato nulla. Però quando cerco di far partire XP lui ci
prova, come faceva prima, poi compare la maledetta finestra blu:
"Si è verificato un problema e Windows è stato arrestato per impedire
danni al computer.
UNMOUNTABLE_BOOT_VOLUME"
Ho scaricato avast e, da Suse, gli ho detto di controllare le cartelle
/windows/C/windows e /windows/D/windows, ma non ha trovato virus.
Si accettano suggerimenti.
Da Suse posso vedere e maneggiare tutte le directory ed i files di
quelle due partizioni. Quindi non è il disco rovinato.
Grazie e ciao,
Un Beppe sotto 30 cm di neve

beppebz schrieb:

[...] Però quando cerco di far partire XP lui ci
prova, come faceva prima, poi compare la maledetta finestra blu:
"Si è verificato un problema e Windows è stato arrestato per impedire
danni al computer.

Maybe it's not a bug but a feature :wink:

UNMOUNTABLE_BOOT_VOLUME"

L'unica cosa che mi viene in mente di controllare sarebbe quale
partizione ha il boot flag.

Mandaci l'output di

fdisk -l /dev/sda

Ciao!
Patrick

Hello

umount -f /device/volume
umount -l /device/volume

try some of there commands

it seems to work

2008/4/9, Patrick Ohnewein <patrick.ohnewein(a)lugbz.org>:

attachment.htm (1.63 KB)