Webcam Probleme

Hola a todos,

io ancora continua a rompere le scatole con la webcam che non funziona,
Michele ho fatto come mi avevi detto tu, mi sono installato il driver
c-qcam.o, questo è il risultato di lsmod:

Module Size Used by Not tainted
c-qcam 10360 0 (unused)
videodev 8288 0 [c-qcam]
ppp_deflate 4536 0 (autoclean)
zlib_deflate 21464 0 (autoclean) [ppp_deflate]
ppp_async 9440 1 (autoclean)
ppp_generic 24380 3 (autoclean) [ppp_deflate ppp_async]
slhc 6740 0 (autoclean) [ppp_generic]
vfat 13084 0 (autoclean)
fat 38712 0 (autoclean) [vfat]
parport_pc 19108 1 (autoclean)
lp 8996 0 (autoclean)
parport 37152 1 (autoclean) [c-qcam parport_pc lp]
sr_mod 18136 0 (autoclean)
es1371 30760 0 (autoclean)
ac97_codec 13384 0 (autoclean) [es1371]
gameport 3396 0 (autoclean) [es1371]
soundcore 6532 4 (autoclean) [es1371]
r128 93176 11
binfmt_misc 7524 1
autofs 13348 0 (autoclean) (unused)
ipt_REJECT 3736 6 (autoclean)
iptable_filter 2412 1 (autoclean)
ip_tables 14936 2 [ipt_REJECT iptable_filter]
microcode 4668 0 (autoclean)
ide-scsi 10512 0
scsi_mod 107176 2 [sr_mod ide-scsi]
ide-cd 33608 0
cdrom 33696 0 [sr_mod ide-cd]
scanner 10420 0 (unused)
mousedev 5524 1
keybdev 2976 0 (unused)
hid 22244 0 (unused)
input 5888 0 [mousedev keybdev hid]
ehci-hcd 17480 0 (unused)
usb-ohci 21320 0 (unused)
usbcore 77024 1 [scanner hid ehci-hcd usb-ohci]
ext3 70368 2
jbd 52212 2 [ext3]

questo è il contenuto del file /proc/bus/usb/device

T: Bus=04 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 6
B: Alloc= 0/800 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 2.04
S: Manufacturer=Linux 2.4.18-14 ehci-hcd
S: Product=PCI device 1039:7002 (Silicon Integrated Systems [SiS])
S: SerialNumber=00:03.3
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=256ms
T: Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 0.00
S: Product=USB OHCI Root Hub
S: SerialNumber=e084d000
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 0.00
S: Product=USB OHCI Root Hub
S: SerialNumber=e084b000
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
T: Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
D: Ver= 1.00 Cls=ff(vend.) Sub=ff Prot=ff MxPS= 8 #Cfgs= 1
P: Vendor=046d ProdID=0840 Rev= 1.00
S: Product=Camera
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E: Ad=81(I) Atr=01(Isoc) MxPS= 0 Ivl=1ms
E: Ad=82(I) Atr=03(Int.) MxPS= 1 Ivl=16ms
I: If#= 0 Alt= 1 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E: Ad=81(I) Atr=01(Isoc) MxPS=1023 Ivl=1ms
E: Ad=82(I) Atr=03(Int.) MxPS= 1 Ivl=16ms
T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 11/900 us ( 1%), #Int= 1, #Iso= 0
D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 0.00
S: Product=USB OHCI Root Hub
S: SerialNumber=e0849000
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=ff(vend.) Sub=00 Prot=ff MxPS= 8 #Cfgs= 1
P: Vendor=03f0 ProdID=0605 Rev= 1.00
S: Manufacturer=Hewlett-Packard
S: Product=HP ScanJet 2200C
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=ff Driver=usbscanner
E: Ad=81(I) Atr=03(Int.) MxPS= 1 Ivl=16ms
E: Ad=82(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=03(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

Non è un problema di USB visto che lo scanner funziona senza problemi.
A questo punto sono sicuro che si tratta di una cazzata ma vorrei sapere perche non mi trovo la webcam in /dev/video0 come dovrebbe?
Grazie mille.

* Antonio Russo (antonio.russo(a)uni.de) wrote:

io ancora continua a rompere le scatole con la webcam che non funziona,
Michele ho fatto come mi avevi detto tu, mi sono installato il driver
c-qcam.o, questo è il risultato di lsmod:

Module Size Used by Not tainted
c-qcam 10360 0 (unused)
videodev 8288 0 [c-qcam]

Ok.

<snip>

parport 37152 1 (autoclean) [c-qcam parport_pc lp]

Hu? Questa riga e' un po' sospetta.. non e' che il driver si aspetta la
webcam su parallela o che?

Ad ogni modo posta il dmesg subito dopo il 'modprobe c-qcam'

Cosi' si capisce se il driver rileva la periferica o se c'e' qualche
altro problema in balle.

mfg,
Michele

Ciao Michele,

adesso ho installato un altro driver, ma lo stesso non mi va, ti rimando un po' di file:

Questo è l'output di lsmod

Module Size Used by Not tainted
ppp_deflate 4536 0 (autoclean)
zlib_deflate 21464 0 (autoclean) [ppp_deflate]
ppp_async 9440 1 (autoclean)
ppp_generic 24380 3 (autoclean) [ppp_deflate ppp_async]
slhc 6740 0 (autoclean) [ppp_generic]
sr_mod 18136 0 (autoclean)
es1371 30760 0 (autoclean)
ac97_codec 13384 0 (autoclean) [es1371]
gameport 3396 0 (autoclean) [es1371]
soundcore 6532 4 (autoclean) [es1371]
r128 93176 3
binfmt_misc 7524 1
parport_pc 19108 1 (autoclean)
lp 8996 0 (autoclean)
parport 37152 1 (autoclean) [parport_pc lp]
autofs 13348 0 (autoclean) (unused)
ipt_REJECT 3736 6 (autoclean)
iptable_filter 2412 1 (autoclean)
ip_tables 14936 2 [ipt_REJECT iptable_filter]
microcode 4668 0 (autoclean)
quickcam 26360 0 (unused)
mod_quickcam 40784 0 [quickcam]
videodev 8288 0 [quickcam mod_quickcam]
scanner 10420 0 (unused)
ide-scsi 10512 0
scsi_mod 107176 2 [sr_mod ide-scsi]
ide-cd 33608 0
cdrom 33696 0 [sr_mod ide-cd]
mousedev 5524 1
keybdev 2976 0 (unused)
hid 22244 0 (unused)
input 5888 0 [mousedev keybdev hid]
ehci-hcd 17480 0 (unused)
usb-ohci 21320 0 (unused)
usbcore 77024 1 [quickcam mod_quickcam scanner hid ehci-hcd usb-ohci]
ext3 70368 2
jbd 52212 2 [ext3]

ancora /proc/bus/usb/devices:

T: Bus=04 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 6
B: Alloc= 0/800 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 2.04
S: Manufacturer=Linux 2.4.18-14 ehci-hcd
S: Product=PCI device 1039:7002 (Silicon Integrated Systems [SiS])
S: SerialNumber=00:03.3
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=256ms
T: Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 0.00
S: Product=USB OHCI Root Hub
S: SerialNumber=e084d000
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 0.00
S: Product=USB OHCI Root Hub
S: SerialNumber=e084b000
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
T: Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
D: Ver= 1.00 Cls=ff(vend.) Sub=ff Prot=ff MxPS= 8 #Cfgs= 1
P: Vendor=046d ProdID=0840 Rev= 1.00
S: Product=Camera
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E: Ad=81(I) Atr=01(Isoc) MxPS= 0 Ivl=1ms
E: Ad=82(I) Atr=03(Int.) MxPS= 1 Ivl=16ms
I: If#= 0 Alt= 1 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E: Ad=81(I) Atr=01(Isoc) MxPS=1023 Ivl=1ms
E: Ad=82(I) Atr=03(Int.) MxPS= 1 Ivl=16ms
T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 11/900 us ( 1%), #Int= 1, #Iso= 0
D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 0.00
S: Product=USB OHCI Root Hub
S: SerialNumber=e0849000
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=ff(vend.) Sub=00 Prot=ff MxPS= 8 #Cfgs= 1
P: Vendor=03f0 ProdID=0605 Rev= 1.00
S: Manufacturer=Hewlett-Packard
S: Product=HP ScanJet 2200C
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=ff Driver=usbscanner
E: Ad=81(I) Atr=03(Int.) MxPS= 1 Ivl=16ms
E: Ad=82(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=03(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

/proc/bus/usb/drivers

         usbdevfs
         hub
96-111: hiddev
         hid
48- 63: usbscanner
         quickcam
         quickcam

Ecco il dmesg

Linux version 2.4.18-14 (bhcompile(a)stripples.devel.redhat.com) (gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)) #1 Wed Sep 4 13:35:50 EDT 2002
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
BIOS-e820: 000000001fff0000 - 000000001fff3000 (ACPI NVS)
BIOS-e820: 000000001fff3000 - 0000000020000000 (ACPI data)
BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
511MB LOWMEM available.
On node 0 totalpages: 131056
zone(0): 4096 pages.
zone(1): 126960 pages.
zone(2): 0 pages.
Kernel command line: ro root=LABEL=/ hdd=ide-scsi
ide_setup: hdd=ide-scsi
Initializing CPU#0
Detected 2019.856 MHz processor.
Speakup v-1.00 CVS: Tue Jun 11 14:22:53 EDT 2002 : initialized
Console: colour VGA+ 80x25
Calibrating delay loop... 4012.86 BogoMIPS
Memory: 511412k/524224k available (1326k kernel code, 10248k reserved, 999k data, 212k init, 0k highmem)
Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
Mount cache hash table entries: 8192 (order: 4, 65536 bytes)
ramfs: mounted with options: <defaults>
ramfs: max_pages=64198 max_file_pages=0 max_inodes=0 max_dentries=64198
Buffer cache hash table entries: 32768 (order: 5, 131072 bytes)
Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
CPU: Before vendor init, caps: 3febfbff 00000000 00000000, vendor = 0
CPU: L1 I cache: 0K, L1 D cache: 8K
CPU: L2 cache: 512K
CPU: After vendor init, caps: 3febfbff 00000000 00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: After generic, caps: 3febfbff 00000000 00000000 00000000
CPU: Common caps: 3febfbff 00000000 00000000 00000000
CPU: Intel(R) Pentium(R) 4 CPU 2.00GHz stepping 04
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch(a)atnf.csiro.au)
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xfad40, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Using IRQ router default [1039/0646] at 00:00.0
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
speakup: initialized device: /dev/synth, node (MAJOR 10, MINOR 25)
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16)
Starting kswapd
VFS: Diskquotas version dquot_6.5.0 initialized
pty: 2048 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI ISAPNP enabled
ttyS0 at 0x03f8 (irq = 4) is a 16550A
ttyS1 at 0x02f8 (irq = 3) is a 16550A
Real Time Clock Driver v1.10e
oprofile: can't get RTC I/O Ports
block: 992 slots per queue, batch=248
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
SIS5513: IDE controller on PCI bus 00 dev 15
SIS5513: chipset revision 0
SIS5513: not 100% native mode: will probe irqs later
SiS646 ATA 133 controller
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA
hda: IC35L040AVVN07-0, ATA DISK drive
hdc: MATSHITADVD-ROM SR-8588, ATAPI CD/DVD-ROM drive
hdd: HL-DT-ST GCE-8480B, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 80418240 sectors (41174 MB) w/1863KiB Cache, CHS=5005/255/63, UDMA(100)
ide-floppy driver 0.99.newide
Partition check:
hda: hda1 hda2 hda3 hda4
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
NET4: Frame Diverter 0.46
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
ide-floppy driver 0.99.newide
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 127k freed
VFS: Mounted root (ext2 filesystem).
Journalled Block Device driver loaded
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel memory: 212k freed
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-ohci.c: USB OHCI at membase 0xe0849000, IRQ 9
usb-ohci.c: usb-00:03.0, Silicon Integrated Systems [SiS] 7001
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb-ohci.c: USB OHCI at membase 0xe084b000, IRQ 5
usb-ohci.c: usb-00:03.1, Silicon Integrated Systems [SiS] 7001 (#2)
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
usb-ohci.c: USB OHCI at membase 0xe084d000, IRQ 11
usb-ohci.c: usb-00:03.2, Silicon Integrated Systems [SiS] 7001 (#3)
usb.c: new USB bus registered, assigned bus number 3
hub.c: USB hub found
hub.c: 2 ports detected
hcd.c: ehci-hcd @ 00:03.3, PCI device 1039:7002 (Silicon Integrated Systems [SiS])
hcd.c: irq 9, pci mem e0855000
usb.c: new USB bus registered, assigned bus number 4
ehci-hcd.c: USB 2.0 support enabled, EHCI rev 1. 0
hub.c: USB hub found
hub.c: 6 ports detected
usb.c: registered new driver hiddev
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech(a)suse.cz>
hid-core.c: USB HID support drivers
mice: PS/2 mouse device common for all mice
EXT3 FS 2.4-0.9.18, 14 May 2002 on ide0(3,2), internal journal
Adding Swap: 1285192k swap-space (priority -1)
hub.c: USB new device connect on bus1/1, assigned device number 2
usb.c: USB device 2 (vend/prod 0x3f0/0x605) is not claimed by any active driver.
hub.c: USB new device connect on bus2/1, assigned device number 2
usb.c: USB device 2 (vend/prod 0x46d/0x840) is not claimed by any active driver.
kjournald starting. Commit interval 5 seconds
EXT3 FS 2.4-0.9.18, 14 May 2002 on ide0(3,3), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
hdc: ATAPI 48X DVD-ROM drive, 256kB Cache
Uniform CD-ROM driver Revision: 3.12
SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: HL-DT-ST Model: CD-RW GCE-8480B Rev: 1.03
  Type: CD-ROM ANSI SCSI revision: 02
usb.c: registered new driver usbscanner
scanner.c: 0.4.6:USB Scanner Driver
Linux video capture interface: v1.00
usb.c: registered new driver quickcam
usb.c: registered new driver quickcam
IA-32 Microcode Update Driver: v1.11 <tigran(a)veritas.com>
microcode: CPU0 no microcode found! (sig=f24, pflags=4)
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
parport0: Printer, EPSON Stylus Photo 810
ohci1394: pci_module_init failed
ip_tables: (C) 2000-2002 Netfilter core team
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
parport0: Printer, EPSON Stylus Photo 810
lp0: using parport0 (polling).
lp0: console ready
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: Unsupported SiS chipset (device id: 0646), you might want to try agp_try_unsupported=1.
agpgart: no supported devices found.
[drm] Initialized r128 2.2.0 20010917 on minor 0
es1371: version v0.30 time 13:45:21 Sep 4 2002
es1371: found chip, vendor id 0x1274 device id 0x5880 revision 0x02
es1371: found es1371 rev 2 at io 0xe000 irq 5
es1371: features: joystick 0x0
ac97_codec: AC97 Audio codec, id: 0x8384:0x7608 (SigmaTel STAC9708)
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
sr0: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray
CSLIP: code copyright 1989 Regents of the University of California
PPP generic driver version 2.4.2
divert: not allocating divert_blk for non-ethernet device ppp0
PPP Deflate Compression module registered

Grazie e buon divertemento :slight_smile:

Hombre(s) :slight_smile:

avete mai sentito parlare della "Mobotix" (ci avete fatto caso alla "ix",
sì, sì, ci gira Linux sopra). Io l'ho provata (nel senso che ero presente a
una demo) e va una meraviglia. Guardare per credere www.mobotix.com

cu
Pasquale

* Antonio Russo (antonio.russo(a)uni.de) wrote:

adesso ho installato un altro driver, ma lo stesso non mi va, ti
rimando un po' di file:

erm..forse facciamo prima se mi dici il modello esatto di webcam che
vuoi utilizzare..che anche a seconda del modello di logitech quickcam
cambia il driver (e per alcuni modelli il driver non c'e' nemmeno..mi
pare di ricordare..)

Ecco il dmesg

L'output del dmesg mi serve subito dopo che hai fatto modprobe
'driver-webcam', cosi' si vede subito se e' stata riconosciuta o se c'e'
stato qualche altro tipo di problema..

Ciao,
Michele

erm..forse facciamo prima se mi dici il modello esatto di webcam che
vuoi utilizzare..che anche a seconda del modello di logitech quickcam
cambia il driver (e per alcuni modelli il driver non c'e' nemmeno..mi
pare di ricordare..)

Io uso una webcam Logitech quickcam express, e infatti penso anchio che
sia un problema di driver:

questa e' la videata di /proc/bus/usb/device

T: Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
D: Ver= 1.00 Cls=ff(vend.) Sub=ff Prot=ff MxPS= 8 #Cfgs= 1
P: Vendor=046d ProdID=0840 Rev= 1.00
S: Product=Camera
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E: Ad=81(I) Atr=01(Isoc) MxPS= 0 Ivl=1ms
E: Ad=82(I) Atr=03(Int.) MxPS= 1 Ivl=16ms
I: If#= 0 Alt= 1 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E: Ad=81(I) Atr=01(Isoc) MxPS=1023 Ivl=1ms
E: Ad=82(I) Atr=03(Int.) MxPS= 1 Ivl=16ms

> Ecco il dmesg
L'output del dmesg mi serve subito dopo che hai fatto modprobe
'driver-webcam', cosi' si vede subito se e' stata riconosciuta o se c'e'
stato qualche altro tipo di problema..

la gestione dei moduli mi sta facendo pure impazzire, questo e' l'output
di lsmod subito dopo l'avvio del computer:

Module Size Used by Not tainted
sg 36556 0 (autoclean)
sr_mod 18136 0 (autoclean)
es1371 30760 0 (autoclean)
ac97_codec 13384 0 (autoclean) [es1371]
gameport 3396 0 (autoclean) [es1371]
soundcore 6532 4 (autoclean) [es1371]
r128 93176 1
binfmt_misc 7524 1
parport_pc 19108 1 (autoclean)
lp 8996 0 (autoclean)
parport 37152 1 (autoclean) [parport_pc lp]
autofs 13348 0 (autoclean) (unused)
ipt_REJECT 3736 6 (autoclean)
iptable_filter 2412 1 (autoclean)
ip_tables 14936 2 [ipt_REJECT iptable_filter]
microcode 4668 0 (autoclean)
quickcam 26360 0 (unused)
mod_quickcam 40784 0 [quickcam]
videodev 8288 0 [quickcam mod_quickcam]
scanner 10420 0
ide-scsi 10512 0
scsi_mod 107176 3 [sg sr_mod ide-scsi]
ide-cd 33608 0
cdrom 33696 0 [sr_mod ide-cd]
mousedev 5524 1
keybdev 2976 0 (unused)
hid 22244 0
input 5888 0 [mousedev keybdev hid]
ehci-hcd 17480 0 (unused)
usb-ohci 21320 0 (unused)
usbcore 77024 1 [quickcam mod_quickcam scanner hid
ehci-hcd usb-ohci]
ext3 70368 2
jbd 52212 2 [ext3]

sembra tutto regolare vero? ma al comando modprobe -r camera mi dice
"device in uso", quindi ho scaricato i moduli videodev e quickcam con
rmmod rispetando le dipendenze e ho caricato nuovamente videodev con
modprobe, infatti questa e' il nuovo output di lsmod

Module Size Used by Not tainted
videodev 8288 0 (unused)
sg 36556 0 (autoclean)
sr_mod 18136 0 (autoclean)
es1371 30760 0 (autoclean)
ac97_codec 13384 0 (autoclean) [es1371]
gameport 3396 0 (autoclean) [es1371]
soundcore 6532 4 (autoclean) [es1371]
r128 93176 1
binfmt_misc 7524 1
parport_pc 19108 1 (autoclean)
lp 8996 0 (autoclean)
parport 37152 1 (autoclean) [parport_pc lp]
autofs 13348 0 (autoclean) (unused)
ipt_REJECT 3736 6 (autoclean)
iptable_filter 2412 1 (autoclean)
ip_tables 14936 2 [ipt_REJECT iptable_filter]
microcode 4668 0 (autoclean)
scanner 10420 0
ide-scsi 10512 0
scsi_mod 107176 3 [sg sr_mod ide-scsi]
ide-cd 33608 0
cdrom 33696 0 [sr_mod ide-cd]
mousedev 5524 1
keybdev 2976 0 (unused)
hid 22244 0
input 5888 0 [mousedev keybdev hid]
ehci-hcd 17480 0 (unused)
usb-ohci 21320 0 (unused)
usbcore 77024 1 [scanner hid ehci-hcd usb-ohci]
ext3 70368 2
jbd 52212 2 [ext3]

fin qui tutto regolare ma quando lancio il commando
modprobe
/lib/modules/2.4.18-14/kernel/drivers/media/video/mod_quickcam.o
questa e' la risposta:
modprobe: Can't locate module
/lib/modules/2.4.18-14/kernel/drivers/media/video/mod_quickcam.o

dmesg:

usb.c: deregistering driver quickcam
usb.c: deregistering driver quickcam
Linux video capture interface: v1.00

dopo di che:

[root(a)localhost root]# insmod
/lib/modules/2.4.18-14/kernel/drivers/media/video/mod_quickcam.o
[root(a)localhost root]# lsmod
Module Size Used by Not tainted
mod_quickcam 40784 0 (unused)
videodev 8288 0 [mod_quickcam]
sg 36556 0 (autoclean)
sr_mod 18136 0 (autoclean)
es1371 30760 0 (autoclean)
ac97_codec 13384 0 (autoclean) [es1371]
gameport 3396 0 (autoclean) [es1371]
soundcore 6532 4 (autoclean) [es1371]
r128 93176 1
binfmt_misc 7524 1
parport_pc 19108 1 (autoclean)
lp 8996 0 (autoclean)
parport 37152 1 (autoclean) [parport_pc lp]
autofs 13348 0 (autoclean) (unused)
ipt_REJECT 3736 6 (autoclean)
iptable_filter 2412 1 (autoclean)
ip_tables 14936 2 [ipt_REJECT iptable_filter]
microcode 4668 0 (autoclean)
scanner 10420 0
ide-scsi 10512 0
scsi_mod 107176 3 [sg sr_mod ide-scsi]
ide-cd 33608 0
cdrom 33696 0 [sr_mod ide-cd]
mousedev 5524 1
keybdev 2976 0 (unused)
hid 22244 0
input 5888 0 [mousedev keybdev hid]
ehci-hcd 17480 0 (unused)
usb-ohci 21320 0 (unused)
usbcore 77024 1 [mod_quickcam scanner hid ehci-hcd
usb-ohci]
ext3 70368 2
jbd 52212 2 [ext3]

dmesg:

usb.c: deregistering driver quickcam
usb.c: deregistering driver quickcam
Linux video capture interface: v1.00
usb.c: registered new driver quickcam

Devo dire che sto imparando un sacco di robe sulla gestione dei
dispositivi USB in GNU/linux, nel fratempo ho fatto funzionare lo
scanner :slight_smile:

Saluti e grazie ancora