[Xvnc] Chi sa come posso far partire gdm?

Ho installato il vncserver trammite xinetd sotto la RH, pensavo che
l'rpm lo faccia per default ma invece, almeno sotto la 7.0 non lo fa,
allora mi son messo a provare un po. Adesso mi parte ma non mi viene il
gdm per fare il login, qualcuno sa come si imposta stafare? Ho gdm
installato e sul X:0 quello originale mi viene anche!

ecco vi mando la sezione del vncserver per il xined.d
------------- file /etc/xinetd.d/vncserver
# description: Start vncserver as a login daemon
service vncserver
{
         port = 5950
         protocol = tcp
         socket_type = stream
         wait = no
         user = nobody
         server = /usr/bin/Xvnc
         server_args = -inetd -broadcast -once -geometry 1152x864
-depth 24
         log_on_failure += USERID
}
------------- -------------

Ho anche provato a fare partire come user gdm o anche come user root,
visto da una mail in una mailing list, ma non è servito a nulla. E poi
penso che user nobody sarebbe adeguato, sicuramente non voglio root.

Sulla pagine del VNC dove descrivono il tutto...
- usano inetd, io uso xinetd ma non dovrebbe essere la causa datoche la
connessione viene effettuata
- usano nebody, anchio lo uso
- dichiarano che problemi di schermate grige sono causate da una mancata
installazione di XDM (o GDM), ma io ce l'ho :frowning:

Be qualcuno sa darmi una mano? O forse sa dove posso trovare + info/doku
su gdm, che la homepage è ultra scarsa.

byez pazzo

forse vnc rompe le palle al vero X perche si apre sul display :0, guarda
se riesci a dirgli di aprirsi su :1 o su un'altro display

ciao, raf

Nono vnc si apre su :1 se :0 è occupato e così via, quello non è un
prob. Il prob è che non viene lanciato gdm ed io non so dove lo si
configura!

byez pazzo

raphael(a)caronte.net wrote:

prova a lanciarlo a mano /etc/init.d/gdm start (sotto deb) e poi vedere
sotto var/log cosa ti scrive. comunque mi sembra strano. noi fai prima a
far girare vnc come demone? comunque i file di configurazione del gdm
stanno sotto /etc/X11/gdm (ribadisco il fatto, sotto deb :slight_smile:

ciao, raf

prova a lanciarlo a mano /etc/init.d/gdm start (sotto deb) e poi vedere

Ma sotto la dep c'è un init-script per gdm, sotto la mia inst non
esiste, sei sicure che non sia gpm?

sotto var/log cosa ti scrive. comunque mi sembra strano. noi fai prima a
far girare vnc come demone?

Attualmente mi gira come demone, ma mi rompe dover far girare x demoni
per x utenti, poi quando va via la luce e il shutdown è forced :slight_smile: dopo
il reboot mi tocca pulire i lock files e rilanciare tutti i vncserver.
Ok, potrei scrivere un script per root, ma mi rompe anche che i wm degli
utenti sono constantemente aperti e mi mangiano cpu cycles e RAM, poi
vogliono tutti usare sto fat-gnome :wink:

comunque i file di configurazione del gdm
stanno sotto /etc/X11/gdm (ribadisco il fatto, sotto deb :slight_smile:

anche da me, ma penso che non sia un problema in gdm.conf, perchè non
viene neanche lanciato, dovrei trovare il luogo dove viene lanciato gdm
stesso.

ciao, raf

byez pazzo

hmm, sei sicuro di avere il gdm installato? :wink:
comunque il gdm è un demone, e perciò in teoria viene lanciato da un'
init script, la debian usa /etc/init.d/gdm, sulle altre distro il nome
può cambiare (a me però pare una stronzata cambiare il nome dello
script). per esempio sotto suse lo script si chiama xdm, e via yast puoi
scegliere tra gdm, kdm, xdm. sotto redhat non mi ricordo. io ho
impostato il login grafico, che sotto debian è configurato in modo molto
intuitivo. il gdm si piazza uno init script sotto /etc/init.d/gdm e poi
si registra alla fine del runlevel 2 sotto /etc/rc2.d/S99gdm.
secondo me per risolvere il problema devi trovare l'init script che
lancia il gdm sotto redhat (prova /etc/init.d/xdm) e poi vedere se è
registrato nell' rc

ciao, raf

Be mi sa che ho trovato chi9 fa lo start del gdm!

[root(a)linux /]# ps -ax | grep dm
   886 ? SW 0:00 [gdm]
   892 ? S 0:00 /etc/X11/X -auth /var/gdm/:0.Xauth :0
   893 ? SW 0:00 [gdm]
   901 ? SW 0:00 [gdmlogin]

sembra che venga lanciato da X indirettamente.

Come si vede il gdm è attivo, ma non so come cavolo si fa a dirli di
ascoltare anche sotto le sessioni del Xvnc, ma ora provo a dare questi
parametri anche al Xvnc, magari funzia.

Ma nessuno ha delle docs a riguardo?

byez pazzo

raphael(a)caronte.net wrote:

Be mi sa che il gdm viene lanciato da
/ect/X11/prefdm

in questo script ho trovato una funzionalità interessante, sembra che si
possa fare uno script col nome /etc/sysconfig/autologin per avere un
autologin, cioè quello che tu (raf) avevi descritto all'ultimo incontro,
sai la feature della mandrake!

byez pazzo

p.s. sono ancora sempre contrario a feature del genere!! :wink:

pohnewein(a)prodata.it wrote:

è gdm a far partire l'X non viceversa.
garda nel file gdm.conf nella sezione [servers], secondo me la soluzione
stà proprio la.

ciao, raf

p.s. alcuni link utili:
http://www.oswg.org/oswg-nightly/oswg/en_US.ISO_8859-1/articles/gdm-reference/gdm-reference.html
http://www.linux.org/docs/ldp/howto/XDMCP-HOWTO/index.html

Sembra proprio la doku che stavo cercando!

thx and byez
pazzo

raphael(a)caronte.net wrote:

Thx to raf!!

Grazie ai links che mi hai dato, ho finalmente trovato l'errore, ed era
un errore da schifo :slight_smile: FYI, il Xvnc communica col gdm trammite un
protocollo apposito, chiamato xdmcp. È un poco insicuro, ma in un
trusted network non dovrei avere problemi. Il potenziale problema è che
questo tipo di protocollo viene usato volentieri per dei DoS, ma non
penso che qui mi vogliano fare robe del genere. Poi il gdm ha delle
possibilità di conf apposite, per proteggersi da questi tipo d'attacchi,
una roba simile al FLOOD_PROTECTION del BitchX.

L'errore, quasi mi vergogno a dirlo, avevo lasciato deattivato l'xdmcp
nel file gdm.conf:
[xdmcp]
Enable=0

dopo aver cambiato in
[xdmcp]
Enable=1

e fatto ripartire il gdm, la cosa funziona da dio, be speriamo fin ora
ho fatto solo un test ;D

thx again

cu pazzo

pohnewein(a)prodata.it wrote: